summaryrefslogtreecommitdiff
path: root/nonprism/gthumb-nonprism/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/gthumb-nonprism/PKGBUILD')
-rw-r--r--nonprism/gthumb-nonprism/PKGBUILD60
1 files changed, 0 insertions, 60 deletions
diff --git a/nonprism/gthumb-nonprism/PKGBUILD b/nonprism/gthumb-nonprism/PKGBUILD
deleted file mode 100644
index 23f56062c..000000000
--- a/nonprism/gthumb-nonprism/PKGBUILD
+++ /dev/null
@@ -1,60 +0,0 @@
-# $Id: PKGBUILD 213426 2014-05-23 22:54:51Z heftig $
-# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-# Contributor (Arch): Jan de Groot <jgc@archlinux.org>
-# Contributor (Arch): Tobias Kieslich <tobias@justdreams.de>
-# Maintainer: André Silva <emulatorman@parabola.nu>
-# Contributor: Márcio Silva <coadde@parabola.nu>
-
-_pkgname=gthumb
-pkgname=gthumb-nonprism
-pkgver=3.2.8
-pkgrel=1
-pkgdesc="Image browser and viewer for the GNOME Desktop, without support for unsafe and dangerous for privacy protocols"
-arch=(i686 x86_64)
-license=(GPL)
-url="http://live.gnome.org/gthumb"
-replaces=($_pkgname)
-conflicts=($_pkgname)
-provides=($_pkgname=$pkgver)
-depends=(desktop-file-utils hicolor-icon-theme dconf librsvg clutter-gtk
- gst-plugins-base-libs gsettings-desktop-schemas libwebp libsecret
- libsoup webkitgtk json-glib)
-makedepends=(intltool libchamplain libopenraw exiv2 itstool brasero librsvg libopenraw liboauth docbook-xsl)
-optdepends=('libopenraw: read RAW files'
- 'exiv2: metadata support'
- 'libchamplain: map viewer'
- 'brasero: burn discs'
- 'liboauth: web albums')
-options=('!emptydirs')
-install=gthumb.install
-source=(http://ftp.gnome.org/pub/GNOME/sources/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.xz
- nonprism.patch)
-sha256sums=('d600aba747af551540f3bbae8e8afa1cc308c658d911318c98fd4bf52ecd61b8'
- '7706181514c9cfe0241329e9b14778dfa2797ddc1feb206b1cd9f07f9be31490')
-
-prepare() {
- cd $_pkgname-$pkgver
- patch -Np1 -i $srcdir/nonprism.patch
-}
-
-build() {
- cd $_pkgname-$pkgver
-
- ./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --disable-static \
- --enable-libchamplain --enable-libopenraw
-
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
-
- make
-}
-
-check() {
- cd $_pkgname-$pkgver
- make check
-}
-
-package() {
- cd $_pkgname-$pkgver
- make DESTDIR="$pkgdir" install
-}