summaryrefslogtreecommitdiff
path: root/nonprism/gnome-weather/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/gnome-weather/PKGBUILD')
-rw-r--r--nonprism/gnome-weather/PKGBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/nonprism/gnome-weather/PKGBUILD b/nonprism/gnome-weather/PKGBUILD
index 498de87a7..946fa8a92 100644
--- a/nonprism/gnome-weather/PKGBUILD
+++ b/nonprism/gnome-weather/PKGBUILD
@@ -1,34 +1,41 @@
-# $Id: PKGBUILD 273833 2016-08-16 00:34:55Z heftig $
+# $Id: PKGBUILD 287540 2017-01-26 20:52:06Z heftig $
# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Maintainer: André Silva <emulatorman@parabola.nu>
pkgname=gnome-weather
pkgver=3.20.2
-pkgrel=1.nonprism1
+pkgrel=2.nonprism1
pkgdesc="Access current weather conditions and forecasts, without geoclue2 support"
url="https://wiki.gnome.org/Apps/Weather"
arch=(any)
license=(GPL)
-depends=(gtk3 gjs libgweather)
-makedepends=(intltool gobject-introspection)
+depends=(gtk3 gjs libgweather gnome-desktop)
+makedepends=(intltool gobject-introspection autoconf-archive appstream-glib git)
groups=(gnome-extra)
-source=(http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver:0:4}/${pkgname}-${pkgver}.tar.xz
+_commit=dc0de147404ca887471990c54f6cd94afe27dcd2 # tags/3.20.2^0
+source=("git+https://git.gnome.org/browse/gnome-weather#commit=$_commit"
nonprism.patch)
-sha256sums=('7823ca7c08fa852232b98c2517830e3bd9b0ab80c9ac83f182c18ec140a5c18b'
- 'ab22a9be5d7a3b1dcaf0fb91febc9f60dfaf1f2c1abfde309da5aa15de6580e8')
+sha256sums=('SKIP'
+ '310d0d1b61e4d791abe6670418ae53d10595f0e7a772d3e73ab59a454385d8be')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
prepare() {
- cd $pkgname-$pkgver
+ cd $pkgname
patch -p1 -i $srcdir/nonprism.patch
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd $pkgname-$pkgver
+ cd $pkgname
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
}
package() {
- cd $pkgname-$pkgver
+ cd $pkgname
make DESTDIR="$pkgdir" install
}