summaryrefslogtreecommitdiff
path: root/nonprism/duplicity-nonprism/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/duplicity-nonprism/PKGBUILD')
-rw-r--r--nonprism/duplicity-nonprism/PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/nonprism/duplicity-nonprism/PKGBUILD b/nonprism/duplicity-nonprism/PKGBUILD
index bd0f54cb9..79163db90 100644
--- a/nonprism/duplicity-nonprism/PKGBUILD
+++ b/nonprism/duplicity-nonprism/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 105116 2014-01-31 20:58:38Z lfleischer $
+# $Id: PKGBUILD 105458 2014-02-08 15:39:04Z bgyorgy $
# Maintainer: Lukas Fleischer <archlinux at cryptocrack dot de>
# Contributor: Kaiting Chen <kaitocracy@gmail.com>
# Contributor: Aaron Schaefer <aaron@elasticdog.com>
@@ -7,7 +7,7 @@
_pkgname=duplicity
pkgname=duplicity-nonprism
pkgver=0.6.23
-pkgrel=2
+pkgrel=3
pkgdesc='A utility for encrypted, bandwidth-efficient backups using the rsync algorithm, without python2-gdata recommendation'
arch=('i686' 'x86_64')
url='http://www.nongnu.org/duplicity/'
@@ -23,9 +23,18 @@ optdepends=('lftp: FTPS backend'
replaces=$_pkgname
conflicts=$_pkgname
provides=$_pkgname=$pkgver
-source=("http://savannah.nongnu.org/download/$_pkgname/$_pkgname-$pkgver.tar.gz"{,.sig})
+source=("http://savannah.nongnu.org/download/$_pkgname/$_pkgname-$pkgver.tar.gz"{,.sig}
+ "gpg-encode.patch")
md5sums=('ae0e84446bcf114735de1057ed53c977'
- 'SKIP')
+ 'SKIP'
+ '366555c73aeebf7f15f6f37ec65176ce')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ # Fix gpg encrypted backup (FS#38838, upstream revision 961, will be fixed in 0.6.24).
+ patch -Np0 -i ../gpg-encode.patch
+}
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"