summaryrefslogtreecommitdiff
path: root/nonprism/banshee/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/banshee/PKGBUILD')
-rw-r--r--nonprism/banshee/PKGBUILD89
1 files changed, 0 insertions, 89 deletions
diff --git a/nonprism/banshee/PKGBUILD b/nonprism/banshee/PKGBUILD
deleted file mode 100644
index 2904d5d85..000000000
--- a/nonprism/banshee/PKGBUILD
+++ /dev/null
@@ -1,89 +0,0 @@
-# $Id: PKGBUILD 141668 2011-11-02 03:17:12Z eric $
-# Maintainer (Arch): Daniel Isenmann <daniel@archlinux.org>
-# Contributor (Arch): György Balló <ballogy@freestart.hu>
-# Maintainer: André Silva <emulatorman@hyperbola.info>
-
-pkgname=banshee
-pkgver=2.6.2
-pkgrel=9.nonprism1
-pkgdesc="Music management and playback for GNOME, without gdata-sharp, Ubuntu One Music store and Amazon MP3 store support"
-arch=('i686' 'x86_64')
-url="http://banshee.fm/"
-license=('MIT')
-depends=(libxxf86vm gst-plugins-base-libs mono-addins dbus-sharp-glib webkitgtk2 libsoup-gnome taglib-sharp gudev-sharp gkeyfile-sharp gconf-sharp libmtp libgpod mono-zeroconf hicolor-icon-theme media-player-info gst-plugins-bad mono-upnp gst-plugins-good gvfs)
-makedepends=('intltool' 'gnome-doc-utils' 'gtk-sharp-beans' 'gnome-common')
-optdepends=('gst-plugins-ugly: Extra media codecs'
- 'gst-libav: Extra media codecs'
- 'brasero: CD burning')
-replaces=(${pkgname}-nonprism)
-conflicts=(${pkgname}-nonprism)
-source=(http://download.gnome.org/sources/$pkgname/2.6/$pkgname-$pkgver.tar.xz
- Initial-port-to-GStreamer-1.0.patch
- Remove-build-time-enable-gapless-playback-option.patch
- Don-t-use-the-new-decoded-pad-signal-of-decodebin.patch
- Use-new-style-GStreamer-1.0-raw-audio-caps-in-the-WA.patch
- sqlite_fix.patch
- Remove-IDBusExportable-inheritance-from-exported-int.patch
- Use-dbus-2.patch
- mono-4.5.patch
- nonprism.patch)
-md5sums=('12dbb8a996783f7081d538062a8589b7'
- '16cbe2ef60e6f9b22015585bb3209648'
- '0bf7ee4241b12538779c9ecc401d142a'
- 'f87534f54029794bd7be2a123ab01300'
- 'd092827720e4a11549587eb3131123ae'
- '2677e6edc2e0d2ce8994adc852dda362'
- '3b28f10e167c0aae27157dcc3b828b67'
- '2c4436f7aba58fdd0c5a38d709d73e5c'
- '0c1dee22d53b18794778f94d198da8e9'
- '6de2436fb9683866f77e71fa8e139b7b')
-
-prepare() {
- cd $pkgname-$pkgver
- patch -p1 -i ../Initial-port-to-GStreamer-1.0.patch
- patch -p1 -i ../Remove-build-time-enable-gapless-playback-option.patch
- patch -p1 -i ../Don-t-use-the-new-decoded-pad-signal-of-decodebin.patch
- patch -p1 -i ../Use-new-style-GStreamer-1.0-raw-audio-caps-in-the-WA.patch
- patch -p1 -i ../sqlite_fix.patch
- patch -p1 -i ../Remove-IDBusExportable-inheritance-from-exported-int.patch
- patch -p1 -i ../Use-dbus-2.patch
- patch -p1 -i ../mono-4.5.patch
-
- NOCONFIGURE=1 ./autogen.sh
-
- # Remove Amazon MP3 store extension since it's mandatory from the building
- patch -p1 -i ../nonprism.patch
- rm -rv src/Extensions/Banshee.AmazonMp3{,.Store}
- rm -rv src/Dap/Banshee.Dap.MassStorage/Banshee.Dap.MassStorage/AmazonMp3GroupSource.cs
- rm -v src/Dap/Banshee.Dap.MassStorage/ThemeIcons/{16x16,22x22}/categories/amazon-mp3-source.png
-}
-
-build() {
- export MONO_SHARED_DIR="$srcdir/.wabi"
- export MCS=/usr/bin/dmcs
- mkdir -p "$MONO_SHARED_DIR"
-
- cd $pkgname-$pkgver
-
- # Disable Youtube extension because it needs gdata-sharp to works. Also disable Ubuntu One Music store too.
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --disable-docs \
- --disable-static \
- --disable-scrollkeeper \
- --disable-schemas-install \
- --disable-boo \
- --disable-youtube \
- --disable-ubuntuone \
- --with-vendor-build-id=Parabola
- make
-}
-
-package() {
- export MONO_SHARED_DIR="$srcdir/.wabi"
- mkdir -p "$MONO_SHARED_DIR"
-
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
-
- install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
-}