summaryrefslogtreecommitdiff
path: root/nonprism/amarok/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/amarok/PKGBUILD')
-rw-r--r--nonprism/amarok/PKGBUILD74
1 files changed, 0 insertions, 74 deletions
diff --git a/nonprism/amarok/PKGBUILD b/nonprism/amarok/PKGBUILD
deleted file mode 100644
index 6e59699e9..000000000
--- a/nonprism/amarok/PKGBUILD
+++ /dev/null
@@ -1,74 +0,0 @@
-# $Id: PKGBUILD 289039 2017-02-16 07:48:33Z arojas $
-# Maintainer (Arch): Ronald van Haren <ronald@archlinux.org>
-# Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
-# Contributor (Arch): damir <damir@archlinux.org>
-# Maintainer: André Silva <emulatorman@hyperbola.info>
-
-# TODO: Remove this package after ArchLinux32 removes it
-# https://git.parabola.nu/blacklist.git/commit/?id=ed7e47d16ddbdf7d9a0829d4882ee4135ac3fa64
-# Already db-remove'd for x86_64 and armv7h
-
-pkgname=amarok
-pkgver=2.8.0
-pkgrel=15.nonprism1
-pkgdesc="The powerful music player for KDE, without Amazon MP3 store support"
-arch=("i686" "x86_64")
-url="http://amarok.kde.org/"
-license=('GPL2' 'LGPL2.1' 'FDL')
-replaces=(${pkgname}-nonprism)
-conflicts=(${pkgname}-nonprism)
-depends=('kdebase-runtime' 'mariadb' 'taglib-extras'
- 'liblastfm' 'ffmpeg' 'libofa' 'qjson' 'qtscriptgenerator')
-makedepends=('pkgconfig' 'automoc4' 'cmake' 'libgpod' 'libmtp' 'loudmouth'
- 'libmygpo-qt' 'mesa')
-optdepends=("libgpod: support for Apple iPod audio devices"
- "libmtp: support for portable media devices"
- "loudmouth: backend needed by mp3tunes for syncing"
- "ifuse: support for Apple iPod Touch and iPhone"
- "libmygpo-qt: gpodder.net Internet Service"
- "gst-libav: MP3 codecs"
- "audiocd-kio4: audio CD support")
-source=("http://download.kde.org/stable/${pkgname}/${pkgver}/src/${pkgname}-${pkgver}.tar.bz2"
- taglib_version_detect.patch amarok-ffmpeg3.patch::"https://git.reviewboard.kde.org/r/126682/diff/raw/"
- amarok-no-qtwebkit.patch amarok-plasma5.7.patch
- remove-amazon-references-on-docs.patch)
-sha1sums=('e76ccd53c05d57f9457d74cd08c2c41383c00937'
- '8b2752a0fe78621bdb9ccdb763919ea265b52b06'
- '819cb060cd9c63b576cc433f835cb4c175b07fd0'
- '9f905eba9e5ead6d704f0cd28e389857c29dc15d'
- '9908c154bf583a1755acf59f9d2790aaff503162'
- 'eed2616fd1465cd16f86f2e3554e3b34b83557af')
-
-prepare() {
- cd ${pkgname}-${pkgver}
- sed -i '\|amzdownloader|d' utilities/CMakeLists.txt
- sed -i '\|amazon|d' src/services/CMakeLists.txt
- patch -Np1 -i ../remove-amazon-references-on-docs.patch
- cd ..
- mkdir build
-
- cd ${pkgname}-${pkgver}
- patch -Np1 -i ../taglib_version_detect.patch
- # fix build against ffmpeg 3.0
- patch -p1 -i ../amarok-ffmpeg3.patch
- # disable applets that require qtwebkit
- patch -p1 -i ../amarok-no-qtwebkit.patch
- # fix tooltips MPRIS controls in Plasma 5.7
- patch -p1 -i ../amarok-plasma5.7.patch
-}
-
-build() {
- cd build
- cmake ../${pkgname}-${pkgver} \
- -DCMAKE_BUILD_TYPE=Release \
- -DKDE4_BUILD_TESTS=OFF \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DWITH_NepomukCore=OFF \
- -DWITH_Soprano=OFF
- make
-}
-
-package(){
- cd build
- make DESTDIR="${pkgdir}" install
-}