summaryrefslogtreecommitdiff
path: root/mozilla-testing/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'mozilla-testing/iceweasel-libre/PKGBUILD')
-rw-r--r--mozilla-testing/iceweasel-libre/PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/mozilla-testing/iceweasel-libre/PKGBUILD b/mozilla-testing/iceweasel-libre/PKGBUILD
index 87169dda0..f7d4df12f 100644
--- a/mozilla-testing/iceweasel-libre/PKGBUILD
+++ b/mozilla-testing/iceweasel-libre/PKGBUILD
@@ -105,12 +105,9 @@ build() {
cd "${srcdir}"
dpkg-source -x ${_debname}_${_debver}-${_debrel}.dsc
- # This will make life more sane
- cd "${srcdir}"
- ln -s "${_debname}-${_debver}" "${_pkgname}-${pkgver}"
-
msg2 "Starting normal build..."
- cd "$srcdir/$_pkgname-$pkgver"
+ mv "${_debname}-${_debver}" "$srcdir/mozilla-build"
+ cd "$srcdir/mozilla-build"
cp "$srcdir/mozconfig" .mozconfig # Load our build config, disable SafeSearch
patch -Np1 -i "$srcdir/iceweasel-install-dir.patch" # install to /usr/lib/$_pkgname
@@ -139,7 +136,7 @@ build() {
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/mozilla-build"
make -j1 -f client.mk DESTDIR="$pkgdir" install
install -m644 "$srcdir"/vendor.js "$pkgdir/usr/lib/$_pkgname/defaults/pref"