summaryrefslogtreecommitdiff
path: root/mozilla-testing/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'mozilla-testing/iceweasel-libre/PKGBUILD')
-rw-r--r--mozilla-testing/iceweasel-libre/PKGBUILD72
1 files changed, 24 insertions, 48 deletions
diff --git a/mozilla-testing/iceweasel-libre/PKGBUILD b/mozilla-testing/iceweasel-libre/PKGBUILD
index 9ade92f8b..c630fbb35 100644
--- a/mozilla-testing/iceweasel-libre/PKGBUILD
+++ b/mozilla-testing/iceweasel-libre/PKGBUILD
@@ -12,15 +12,15 @@ _pgo=false
# We're getting this from Debian Sid
_debname=iceweasel
-_debver=9.0.1
-_debrel=1
+_debver=10.0
+_debrel=2
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
_pkgname=iceweasel
pkgname=iceweasel-libre
pkgver=${_debver}.${_debrel}
-pkgrel=2.1
+pkgrel=1
if [ -z "$pkgname" ]; then pkgname=$_pkgname; fi
if $_pgo; then
@@ -30,40 +30,8 @@ fi
pkgdesc="A libre version of Debian Iceweasel, the browser based on Mozilla Firefox."
arch=('i586' 'i686' 'x86_64' 'mips64el')
license=('GPL2' 'MPL' 'LGPL')
-depends=(
- 'alsa-lib'
- 'dbus-glib'
- 'desktop-file-utils'
- 'gtk2'
- 'hicolor-icon-theme'
- 'hunspell'
- 'libevent'
- 'libnotify'
- 'libvpx'
- 'libxt'
- 'mime-types'
- 'mozilla-common'
- 'mozilla-searchplugins'
- 'nss>=3.13.1'
- 'sqlite3'
- 'startup-notification'
-)
-makedepends=(
- 'autoconf2.13'
- 'diffutils'
- 'imagemagick'
- 'libidl2'
- 'librsvg'
- 'libxslt'
- 'mesa'
- 'pkg-config'
- 'python2'
- 'quilt'
- 'unzip'
- 'wireless_tools'
- 'yasm'
- 'zip'
-)
+depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'hicolor-icon-theme' 'hunspell' 'libevent' 'libnotify' 'libvpx' 'libxt' 'mime-types' 'mozilla-common' 'mozilla-searchplugins' 'nss>=3.13.1' 'sqlite3' 'startup-notification')
+makedepends=( 'autoconf2.13' 'diffutils' 'imagemagick' 'libidl2' 'librsvg' 'libxslt' 'mesa' 'pkg-config' 'python2' 'quilt' 'unzip' 'wireless_tools' 'yasm' 'zip')
if $_pgo; then
makedepends+=('xorg-server-xvfb')
options=(!ccache)
@@ -81,6 +49,16 @@ source=("${_debrepo}/`debfile ${_debname}`_${_debver}.orig.tar.bz2"
iceweasel-install-dir.patch
region.properties
vendor.js)
+md5sums=('bc86bf0d74649f9b3fcde6dfa914141e'
+ '131782b1ca9d24f40dff8f456558988d'
+ '659b08b8f14429dd1b7f9229b6fbd1b2'
+ 'eab149c1994ab14392e55af3abb08e80'
+ 'ac29b01c189f20abae2f3eef1618ffc0'
+ 'a485a2b5dc544a8a2bd40c985d2e5813'
+ '24fb7dba021ef94a351ebd3750cc0451'
+ 'e529742c0a425648087bc3ce537fe4c5'
+ 'f1c76e7e244257856a386ca2de69bdf0'
+ '0d053487907de4376d67d8f499c5502b')
if [ "$_pkgname" != "$pkgname" ]; then
provides+=("$_pkgname=$pkgver")
@@ -95,12 +73,18 @@ dpkg-source() {
mv mozilla-release "${_debname}-${_debver}"
mv debian "${_debname}-${_debver}"
cd "${_debname}-${_debver}"
+
+# Doesn't apply and seems unimportant
+ rm -v debian/patches/l10n/Place-google-and-gmail-before-yandex.patch || true
+
quilt push -a
find .pc -name .timestamp -delete # why isn't "--no-timestamps" doing this?
cd ..
}
build() {
+# Don't run this if we're using -e
+if [ $NOEXTRACT -eq 0 ]; then
msg2 "Applying Debian patches..."
cd "${srcdir}"
dpkg-source -x ${_debname}_${_debver}-${_debrel}.dsc
@@ -113,6 +97,9 @@ build() {
patch -Np1 -i "$srcdir/iceweasel-install-dir.patch" # install to /usr/lib/$_pkgname
patch -Np1 -i "$srcdir/xulrunner-copy-stub.patch" # small fix
patch -Np1 -i "$srcdir/libre.patch"
+fi
+
+ cd "$srcdir/mozilla-build"
cp -f ${srcdir}/region.properties ./browser/locales/en-US/chrome/browser-region/
if $_pgo; then
@@ -167,14 +154,3 @@ package() {
# Workaround for now: https://bugzilla.mozilla.org/show_bug.cgi?id=658850
ln -sf $_pkgname "$pkgdir/usr/lib/$_pkgname/$_pkgname-bin"
}
-
-md5sums=('bd656a24d0ba3d4ca7b68aca8081a07d'
- '6cde9fe38df1434fdcc0f3a078b0238e'
- 'd9b5f2a893ad80da492aec8c9a7cbb7c'
- 'eab149c1994ab14392e55af3abb08e80'
- 'ac29b01c189f20abae2f3eef1618ffc0'
- 'a485a2b5dc544a8a2bd40c985d2e5813'
- '3c1a7d6984b47a0ab36a5d8e6672cb2b'
- 'e529742c0a425648087bc3ce537fe4c5'
- 'f1c76e7e244257856a386ca2de69bdf0'
- '0d053487907de4376d67d8f499c5502b')