summaryrefslogtreecommitdiff
path: root/mozilla-testing/icecat/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'mozilla-testing/icecat/PKGBUILD')
-rw-r--r--mozilla-testing/icecat/PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/mozilla-testing/icecat/PKGBUILD b/mozilla-testing/icecat/PKGBUILD
index 9f8854084..4379ee60c 100644
--- a/mozilla-testing/icecat/PKGBUILD
+++ b/mozilla-testing/icecat/PKGBUILD
@@ -77,7 +77,8 @@ if [ "$_pkgname" != "$pkgname" ]; then
fi
build() {
- cd "$srcdir/$_pkgname-$pkgver"
+ mv "$_pkgname-$pkgver" "$srcdir/mozilla-build"
+ cd "$srcdir/mozilla-build"
cp "$srcdir/mozconfig" .mozconfig # Load our build config, disable SafeSearch
patch -Np1 -i "$srcdir/firefox-install-dir.patch" # install to /usr/lib/$pkgname
@@ -104,7 +105,7 @@ build() {
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/mozilla-build"
make -j1 -f client.mk DESTDIR="$pkgdir" install
install -m644 "$srcdir"/vendor.js "$pkgdir/usr/lib/$_pkgname/defaults/pref"