summaryrefslogtreecommitdiff
path: root/libre/xorg-server/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/xorg-server/PKGBUILD')
-rw-r--r--libre/xorg-server/PKGBUILD145
1 files changed, 145 insertions, 0 deletions
diff --git a/libre/xorg-server/PKGBUILD b/libre/xorg-server/PKGBUILD
new file mode 100644
index 000000000..62d43726b
--- /dev/null
+++ b/libre/xorg-server/PKGBUILD
@@ -0,0 +1,145 @@
+# $Id: PKGBUILD 218446 2014-07-31 12:02:24Z lcarlier $
+# Maintainer (Parabola): Márcio Silva <coadde@parabola.nu>
+# Maintainer: AndyRTR <andyrtr@archlinux.org>
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgbase=xorg-server
+pkgname=('xorg-server')
+pkgver=1.16.0
+pkgrel=6.parabola1 # build first with 0.1 and then rebuild it after xf86-input-evdev rebuild
+arch=('i686' 'x86_64' 'mips64el')
+license=('custom')
+url="http://xorg.freedesktop.org"
+makedepends=('pixman' 'libx11' 'mesa' 'mesa-libgl' 'xf86driproto' 'xcmiscproto' 'xtrans' 'bigreqsproto' 'randrproto'
+ 'inputproto' 'fontsproto' 'videoproto' 'presentproto' 'compositeproto' 'recordproto' 'scrnsaverproto'
+ 'resourceproto' 'xineramaproto' 'libxkbfile' 'libxfont' 'renderproto' 'libpciaccess' 'libxv'
+ 'xf86dgaproto' 'libxmu' 'libxrender' 'libxi' 'dmxproto' 'libxaw' 'libdmx' 'libxtst' 'libxres'
+ 'xorg-xkbcomp' 'xorg-util-macros' 'xorg-font-util' 'glproto' 'dri2proto' 'libgcrypt' 'libepoxy'
+ 'xcb-util' 'xcb-util-image' 'xcb-util-wm' 'xcb-util-keysyms' 'dri3proto' 'libxshmfence')
+source=(${url}/releases/individual/xserver/${pkgbase}-${pkgver}.tar.bz2{,.sig}
+ autoconfig-nvidia-libre.patch
+ autoconfig-sis.patch
+ glamor-upstream-fix.patch
+ xvfb-run
+ xvfb-run.1)
+sha256sums=('38330a03c5f7a38745a3f9816cf069db5b8844eebb358fd39dbabf61f32cd06b'
+ 'SKIP'
+ 'eca387a72345ac9cce866a8ca3b31e6ef696f298be4863196da75009c6673363'
+ 'd027776fac1f7675b0a9ee817502290b1c45f9c09b0f0a6bb058c35f92361e84'
+ 'fbd898f0e867c77c9bf918fd2e7956c7776ecb3cc3634c61290fb03513b47987'
+ 'ff0156309470fc1d378fd2e104338020a884295e285972cc88e250e031cc35b9'
+ '2460adccd3362fefd4cdc5f1c70f332d7b578091fb9167bf88b5f91265bbd776')
+
+prepare() {
+ cd "${pkgbase}-${pkgver}"
+ # Use unofficial imedia SiS driver for supported SiS devices
+ patch -Np0 -i ../autoconfig-sis.patch
+ # NV01 (Diamond Edge 3D) and NV03 (Riva 128) is not supported by nouveau:
+ # http://nouveau.freedesktop.org/wiki/CodeNames/#Ancient
+ # Use nouveau/nv/vesa drivers for nvidia devices
+ # Note: nonfree "nvidia" driver support was removed on our patch version
+ patch -Np1 -i ../autoconfig-nvidia-libre.patch
+ # merged upstream (1.16 branch)
+ patch -Np1 -i ../glamor-upstream-fix.patch
+
+ # fix os name:
+ #Build Operating System = OSNAME="--kernel-name --kernel-release --machine" OSVENDOR=""
+ #Current Operating System = --kernel-name --nodename --kernel-release --kernel-version --machine
+ # to:
+ #Build Operating System = OSNAME="--operating-system" OSVENDOR="--machine - kernel --kernel-release"
+ #Current Operating System = OSNAME="--operating-system" --nodename --machine - kernel --kernel-release --kernel-version
+ # see: man uname
+
+ sed -i '\|Current Operating System| s|%s %s %s %s %s|%s %s %s - kernel %s %s|
+ s|name.sysname, name.nodename, name.release|OSNAME, name.nodename, name.machine|
+ s|name.version, name.machine|name.release, name.version|
+ ' hw/xfree86/common/xf86Init.c
+ sed -i 's|Linux|GNU/Linux|
+ s|GNU Hurd|GNU/Hurd|
+ ' hw/xfree86/man/{Xorg,xorg.conf}.man
+ sed -i 's|uname -srm|uname -o|
+ s|uname -s|uname -o|
+ ' ChangeLog config.guess configure.ac configure compile
+}
+
+build() {
+ cd "${pkgbase}-${pkgver}"
+ autoreconf -fi
+ ./configure --prefix=/usr \
+ --enable-ipv6 \
+ --enable-dri \
+ --enable-dmx \
+ --enable-xvfb \
+ --enable-xnest \
+ --enable-composite \
+ --enable-xcsecurity \
+ --enable-xorg \
+ --enable-xephyr \
+ --enable-glamor \
+ --enable-xwayland \
+ --enable-glx-tls \
+ --enable-kdrive \
+ --enable-kdrive-evdev \
+ --enable-kdrive-kbd \
+ --enable-kdrive-mouse \
+ --enable-config-udev \
+ --enable-systemd-logind \
+ --enable-suid-wrapper \
+ --disable-install-setuid \
+ --enable-record \
+ --disable-xfbdev \
+ --disable-xfake \
+ --disable-static \
+ --libexecdir=/usr/bin \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-xkb-path=/usr/share/X11/xkb \
+ --with-xkb-output=/var/lib/xkb \
+ --with-fontrootdir=/usr/share/fonts \
+ --with-os-name="$(uname -o)" \
+ --with-os-vendor="$(uname -m) - kernel $(uname -r)"
+
+# --without-dtrace \
+# --disable-linux-acpi --disable-linux-apm \
+
+ make
+
+ # Disable subdirs for make install rule to make splitting easier
+ sed -e 's/^DMX_SUBDIRS =.*/DMX_SUBDIRS =/' \
+ -e 's/^XVFB_SUBDIRS =.*/XVFB_SUBDIRS =/' \
+ -e 's/^XNEST_SUBDIRS =.*/XNEST_SUBDIRS = /' \
+ -e 's/^KDRIVE_SUBDIRS =.*/KDRIVE_SUBDIRS =/' \
+ -e 's/^XWAYLAND_SUBDIRS =.*/XWAYLAND_SUBDIRS =/' \
+ -i hw/Makefile
+}
+
+package_xorg-server() {
+ pkgdesc="Xorg X server, without nonfree nvidia driver support"
+ depends=(libepoxy libxdmcp libxfont libpciaccess libdrm pixman libgcrypt libxau xorg-server-common xf86-input-evdev libxshmfence)
+ # see xorg-server-*/hw/xfree86/common/xf86Module.h for ABI versions - we provide major numbers that drivers can depend on
+ # and /usr/lib/pkgconfig/xorg-server.pc in xorg-server-devel pkg
+ provides=('X-ABI-VIDEODRV_VERSION=18' 'X-ABI-XINPUT_VERSION=21' 'X-ABI-EXTENSION_VERSION=8.0' 'x-server')
+ groups=('xorg')
+ conflicts=('nvidia-utils' 'glamor-egl' "${pkgbase}-libre" "${pkgbase}-parabola")
+ replaces=('nvidia-utils' 'glamor-egl' "${pkgbase}-libre" "${pkgbase}-parabola")
+ install=xorg-server.install
+
+ cd "${pkgbase}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ # Needed for non-mesa drivers, libgl will restore it
+ mv "${pkgdir}/usr/lib/xorg/modules/extensions/libglx.so" \
+ "${pkgdir}/usr/lib/xorg/modules/extensions/libglx.xorg"
+
+ rm -rf "${pkgdir}/var"
+
+ rm -f "${pkgdir}/usr/share/man/man1/Xserver.1"
+ rm -f "${pkgdir}/usr/lib/xorg/protocol.txt"
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/xorg-server"
+ ln -sf ../xorg-server-common/COPYING "${pkgdir}/usr/share/licenses/xorg-server/COPYING"
+
+ rm -rf "${pkgdir}/usr/lib/pkgconfig"
+ rm -rf "${pkgdir}/usr/include"
+ rm -rf "${pkgdir}/usr/share/aclocal"
+}