summaryrefslogtreecommitdiff
path: root/libre/uboot-cubox-linux-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/uboot-cubox-linux-libre/PKGBUILD')
-rw-r--r--libre/uboot-cubox-linux-libre/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/libre/uboot-cubox-linux-libre/PKGBUILD b/libre/uboot-cubox-linux-libre/PKGBUILD
new file mode 100644
index 000000000..17d8c0c9b
--- /dev/null
+++ b/libre/uboot-cubox-linux-libre/PKGBUILD
@@ -0,0 +1,27 @@
+# U-Boot: Cubox (Dove)
+# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+buildarch=4
+
+_pkgname=linux-libre
+pkgname=uboot-cubox-${_pkgname}
+pkgver=2009.08
+pkgrel=1
+pkgdesc="U-Boot for CuBox (Dove) (built for the linux-libre kernel package)"
+arch=('armv7h')
+url="http://git.denx.de/u-boot.git/"
+license=('GPL')
+makedepends=('uboot-tools')
+depends=('linux-libre')
+replaces=('uboot-cubox')
+backup=("boot/${pkgname}/boot.scr")
+_commit=814386d3e43b8ab8d81f04aa7fe402952503d8fe
+source=('boot.txt')
+md5sums=('96fdd33ef33cb55d50e97dbd86a871a3')
+
+package() {
+ mkimage -A arm -O linux -T script -C none -n "Boot script" -d boot.txt boot.scr
+ mkdir -p "${pkgdir}/boot/${pkgname}"
+ cp boot.scr "${pkgdir}/boot/${pkgname}"
+}