summaryrefslogtreecommitdiff
path: root/libre/uboot-beaglebone-linux-libre-lts/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/uboot-beaglebone-linux-libre-lts/PKGBUILD')
-rw-r--r--libre/uboot-beaglebone-linux-libre-lts/PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/libre/uboot-beaglebone-linux-libre-lts/PKGBUILD b/libre/uboot-beaglebone-linux-libre-lts/PKGBUILD
new file mode 100644
index 000000000..1929e3369
--- /dev/null
+++ b/libre/uboot-beaglebone-linux-libre-lts/PKGBUILD
@@ -0,0 +1,45 @@
+# U-Boot: Beaglebone and Beaglebone Black
+# Maintainer (Arch): Kevin Mihelich <kevin@archlinuxarm.org>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+buildarch=4
+
+_pkgname=linux-libre-lts
+pkgname=uboot-beaglebone-${_pkgname}
+pkgver=2015.04
+pkgrel=1.1
+pkgdesc="U-Boot for Beaglebone and Beaglebone Black (built for the linux-libre-lts kernel package)"
+arch=('armv7h')
+url="http://git.denx.de/u-boot.git/"
+depends=('linux-libre-lts')
+makedepends=('bc')
+replaces=('uboot-beaglebone')
+license=('GPL')
+install=${pkgname}.install
+source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
+ '0001-parabola-arm-modifications.patch'
+ 'uEnv.txt')
+md5sums=('570bdc2c47270c2a98ca60ff6c5c74cd'
+ '866dc9001d2d0d3e6b3d3b3c7ffced53'
+ 'ccb79775b81654e16fca18825c7f2506')
+
+prepare() {
+ cd u-boot-${pkgver}
+ patch -Np1 -i ../0001-parabola-arm-modifications.patch
+}
+
+build() {
+ cd u-boot-${pkgver}
+
+ unset CFLAGS CXXFLAGS LDFLAGS
+
+ make distclean
+ make am335x_evm_config
+ make
+}
+
+package() {
+ cd u-boot-${pkgver}
+ mkdir -p "${pkgdir}/boot/${pkgname}"
+ cp MLO u-boot.img "${srcdir}"/uEnv.txt "${pkgdir}/boot/${pkgname}"
+}