summaryrefslogtreecommitdiff
path: root/libre/uboot-beaglebone-linux-libre-grsec/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/uboot-beaglebone-linux-libre-grsec/PKGBUILD')
-rw-r--r--libre/uboot-beaglebone-linux-libre-grsec/PKGBUILD44
1 files changed, 0 insertions, 44 deletions
diff --git a/libre/uboot-beaglebone-linux-libre-grsec/PKGBUILD b/libre/uboot-beaglebone-linux-libre-grsec/PKGBUILD
deleted file mode 100644
index 39a57b143..000000000
--- a/libre/uboot-beaglebone-linux-libre-grsec/PKGBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# U-Boot: BeagleBone and BeagleBone Black
-# Maintainer (Arch): Kevin Mihelich <kevin@archlinuxarm.org>
-# Contributor: André Silva <emulatorman@parabola.nu>
-
-buildarch=4
-
-_pkgname=linux-libre-grsec
-pkgname=uboot-beaglebone-${_pkgname}
-pkgver=2015.04
-pkgrel=1.2
-pkgdesc="U-Boot for BeagleBone and BeagleBone Black (built for the linux-libre-grsec kernel package)"
-arch=('armv7h')
-url="http://git.denx.de/u-boot.git/"
-depends=('linux-libre-grsec')
-makedepends=('bc')
-license=('GPL')
-install=${pkgname}.install
-source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
- '0001-parabola-arm-modifications.patch'
- 'uEnv.txt')
-md5sums=('570bdc2c47270c2a98ca60ff6c5c74cd'
- 'e8d6cc3bdc37c135084becc446053dec'
- 'ccb79775b81654e16fca18825c7f2506')
-
-prepare() {
- cd u-boot-${pkgver}
- patch -Np1 -i ../0001-parabola-arm-modifications.patch
-}
-
-build() {
- cd u-boot-${pkgver}
-
- unset CFLAGS CXXFLAGS LDFLAGS
-
- make distclean
- make am335x_evm_config
- make
-}
-
-package() {
- cd u-boot-${pkgver}
- mkdir -p "${pkgdir}/boot/${pkgname}"
- cp MLO u-boot.img "${srcdir}"/uEnv.txt "${pkgdir}/boot/${pkgname}"
-}