summaryrefslogtreecommitdiff
path: root/libre/tp_smapi/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/tp_smapi/PKGBUILD')
-rw-r--r--libre/tp_smapi/PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/libre/tp_smapi/PKGBUILD b/libre/tp_smapi/PKGBUILD
index c7f3b1b07..a6d06d042 100644
--- a/libre/tp_smapi/PKGBUILD
+++ b/libre/tp_smapi/PKGBUILD
@@ -11,19 +11,19 @@
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-_basekernel=5.7.10-1
+_basekernel=5.8.3
pkgname=tp_smapi
pkgver=0.43
pkgrel=224
-pkgrel+=.parabola1.basekernel${_basekernel%-*}
+pkgrel+=.parabola1.basekernel${_basekernel}
pkgdesc="Modules for ThinkPad's SMAPI functionality"
pkgdesc+=" (for linux-libre)"
arch=('x86_64')
arch+=('i686')
url='https://github.com/evgeni/tp_smapi'
license=('GPL')
-makedepends=(linux-libre-headers=${_basekernel%-*} git libelf)
+makedepends=(linux-libre-headers=${_basekernel} git libelf)
_commit=a63729ab30d85430048f65c37f29188ab484cd52 # tags/tp-smapi/0.43
source=("git+https://github.com/evgeni/tp_smapi#commit=$_commit")
sha256sums=('SKIP')
@@ -43,7 +43,7 @@ build() {
}
package() {
- depends=(linux-libre=${_basekernel%-*})
+ depends=(linux-libre=${_basekernel})
local extradir=/usr/lib/modules/$(</usr/src/linux-libre/version)/extramodules
cd $pkgname