summaryrefslogtreecommitdiff
path: root/libre/texlive-bin/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/texlive-bin/PKGBUILD')
-rw-r--r--libre/texlive-bin/PKGBUILD61
1 files changed, 36 insertions, 25 deletions
diff --git a/libre/texlive-bin/PKGBUILD b/libre/texlive-bin/PKGBUILD
index ca3d2d5b1..d7615abac 100644
--- a/libre/texlive-bin/PKGBUILD
+++ b/libre/texlive-bin/PKGBUILD
@@ -8,11 +8,13 @@
# parabola changes and rationale:
# - rebranded to parabola
+# - versioned dependencies to mitigate breakage from Arch's .so bumps
+# - diable xindy on armv7h
pkgname=('texlive-bin')
-pkgver=2017.44590
-pkgrel=14
-pkgrel+=.parabola2
+pkgver=2018.47465
+pkgrel=2
+pkgrel+=.parabola1
license=('GPL')
arch=('x86_64')
arch+=('i686' 'armv7h')
@@ -20,43 +22,40 @@ makedepends=('cairo' 'pixman' 'graphite' 't1lib' 'gd' 'poppler'
'libsigsegv' 'zziplib' 'libpng' 'libjpeg' 'freetype2'
'icu' 'harfbuzz' 'harfbuzz-icu' 'gmp' 'mpfr' 'potrace' 'libpaper'
'perl' 'clisp' 'ffcall')
-case "$CARCH" in
- i686)
- makedepends+=('poppler=0.63.0' 'icu>=61' 'icu<62') ;;
- armv7h|x86_64)
- makedepends+=('poppler=0.64.0' 'icu>=61' 'icu<62') ;;
-esac
+makedepends+=('poppler=0.64.0' 'icu>=61' 'icu<62')
url='http://tug.org/texlive/'
source=("https://sources.archlinux.org/other/texlive/texlive-bin-source-${pkgver}.tar.xz"
- "luatex-gcc7.patch"
- "texlive-poppler-0.59.patch"
- "pdftex-poppler-0.59.patch"
- "texlive-poppler-0.64.patch")
-sha256sums=('4645b4d55fc500ba9be7156a6a330afb44fbf7fda40dfd73fe9cb16d207f2038'
- 'ee97f3e07e235dee4ad6d0c3e85c2260914c965e94d5ffbf481fa506df5f01ec'
- 'a5204f110f261de989fc21f93a4b5485876ea2d28773bcdc4817b548fd865024'
- 'c7246156104f8e57e80b6fc3a9c9efec7542cd067a525fb51279a15056de4426'
- '02c75172cd25c54acf3d998bf79ef6915e611c9dbb2821638f3289dc87d7479a')
+ "texlive-poppler-0.64.patch"
+ "freetype-pkgconfig.patch"
+ "synctex-missing-header.patch")
+sha256sums=('06d7a1c939cf7d6035850cefca1d01898ae51a879e20db684a202fd507a0cae5'
+ '1c444526e3967f82d68a003526b332e0401db7825e22b5542e6cd04f0e688310'
+ 'bed44f4ccda369410e90eac527cf44b8c1afda7d987ae521b4fd5edb425eef3e'
+ 'b6c81eb091b5910226e0359768edd178680debee56b63ab0a3753c3429c28ab0')
prepare() {
cd "$srcdir/source"
+ # Synctex "make install" misses synctex_version.h
+ patch -Np1 -i "${srcdir}/synctex-missing-header.patch"
+
+ # Freetype2 2.9.1 package no longer has freetype-config
+ patch -Np1 -i "${srcdir}/freetype-pkgconfig.patch"
+ ./reautoconf
+
# t4ht expects to be un /usr/share/texmf/bin/t4ht (FS#27251)
sed -i s/SELFAUTOPARENT/TEXMFROOT/ texk/tex4htk/t4ht.c
## prevent compiling Xdvi with libXp
sed -i~ 's|-lXp ||' texk/xdvik/configure
- # Luatex crashes when compiled with GCC7.1
- patch -Np0 -i "${srcdir}/luatex-gcc7.patch"
+ # Poppler 0.64 now returns const char* in getCString()
+ patch -Np1 -i "${srcdir}/texlive-poppler-0.64.patch"
# Poppler 0.58 introduces API changes by hiding internal object
# management.
- patch -Np1 -i "${srcdir}/texlive-poppler-0.59.patch"
- patch -Np1 -i "${srcdir}/pdftex-poppler-0.59.patch"
-
- # Poppler 0.64 now returns const char* in getCString()
- patch -Np1 -i "${srcdir}/texlive-poppler-0.64.patch"
+ cp -pv texk/web2c/pdftexdir/pdftoepdf{-newpoppler.cc,.cc}
+ cp -pv texk/web2c/pdftexdir/pdftosrc{-newpoppler.cc,.cc}
}
build() {
@@ -187,10 +186,13 @@ package_texlive-bin() {
# remove dangling symlinks
_bibtexextra_scripts="
bbl2bib
+bib2gls
bibdoiadd
bibexport
bibmradd
+biburl2doi
bibzbladd
+convertgls2bib
listbib
ltx2crossrefxml
multibibliography
@@ -216,6 +218,7 @@ context
contextjit
ctanify
ctanupload
+ctan-o-mat
de-macro
depythontex
deweb
@@ -223,6 +226,7 @@ dosepsbin
dtxgen
dvi2fax
dviasm
+dviinfox
dvired
e2pall
epstopdf
@@ -241,6 +245,7 @@ httexi
htxelatex
htxetex
installfont-tl
+jfmutil
kpsepath
kpsetool
kpsewhere
@@ -249,6 +254,7 @@ latex-git-log
latex-papersize
latex2man
latex2nemeth
+latexdef
latexdiff
latexdiff-vc
latexfileversion
@@ -326,6 +332,8 @@ texosquery
texosquery-jre5
texosquery-jre8
thumbpdf
+tlcockpit
+tlshell
typeoutfileinfo
updmap
updmap-sys
@@ -353,6 +361,7 @@ kanji-config-updmap-user
_latexextra_scripts="
authorindex
exceltex
+l3build
makedtx
makeglossaries
makeglossaries-lite
@@ -362,6 +371,7 @@ ps4pdf
splitindex
svn-multi
vpe
+wordcount
yplan"
_music_scripts="lily-glyph-commands lily-image-commands lily-rebuild-pdfs
m-tx musixtex musixflx pmxchords"
@@ -403,3 +413,4 @@ pn2pdf"
rm -f "$pkgdir"/usr/lib/pkgconfig/synctex.pc
rm -f "$pkgdir"/usr/share/man/man*/synctex.*
}
+