summaryrefslogtreecommitdiff
path: root/libre/systemd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/systemd/PKGBUILD')
-rw-r--r--libre/systemd/PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/libre/systemd/PKGBUILD b/libre/systemd/PKGBUILD
index 5f16c3cce..dff535123 100644
--- a/libre/systemd/PKGBUILD
+++ b/libre/systemd/PKGBUILD
@@ -4,8 +4,8 @@
pkgbase=systemd
pkgname=systemd
-pkgver=225
-pkgrel=1.parabola2
+pkgver=226
+pkgrel=1.parabola1
arch=('i686' 'x86_64')
url="http://www.freedesktop.org/wiki/Software/systemd"
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam'
@@ -28,10 +28,10 @@ md5sums=('SKIP'
'1b3aa3a0551b08af9305d33f85b5c2fc'
'36ee74767ac8734dede1cbd0f4f275d7'
'9b9f4a58e4c4009bf5290c5b297600c3'
- '5d7e15f4bd660cba06a7323b53c1e777')
+ '15b4bd1982d5d263f12806b0b1dc3e96')
prepare() {
- cd "$pkgname"
+ cd "$pkgbase"
# Rename "Linux" -> "GNU/Linux"
patch -Np1 -i "$srcdir/gnu+linux.patch"
@@ -46,7 +46,7 @@ prepare() {
}
build() {
- cd "$pkgname"
+ cd "$pkgbase"
local timeservers=({0..3}.arch.pool.ntp.org)
@@ -103,7 +103,7 @@ package_systemd() {
etc/udev/udev.conf)
install="systemd.install"
- make -C "$pkgname" DESTDIR="$pkgdir" install
+ make -C "$pkgbase" DESTDIR="$pkgdir" install
# don't write units to /etc by default. some of these will be re-enabled on
# post_install.
@@ -113,7 +113,7 @@ package_systemd() {
rm -r "$pkgdir/usr/lib/rpm"
# add back tmpfiles.d/legacy.conf
- install -m644 "$pkgname/tmpfiles.d/legacy.conf" "$pkgdir/usr/lib/tmpfiles.d"
+ install -m644 "$pkgbase/tmpfiles.d/legacy.conf" "$pkgdir/usr/lib/tmpfiles.d"
# Replace dialout/tape/cdrom group in rules with uucp/storage/optical group
sed -i 's#GROUP="dialout"#GROUP="uucp"#g;