summaryrefslogtreecommitdiff
path: root/libre/systemd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/systemd/PKGBUILD')
-rw-r--r--libre/systemd/PKGBUILD33
1 files changed, 9 insertions, 24 deletions
diff --git a/libre/systemd/PKGBUILD b/libre/systemd/PKGBUILD
index 77dfb2b46..2c78bd517 100644
--- a/libre/systemd/PKGBUILD
+++ b/libre/systemd/PKGBUILD
@@ -11,10 +11,9 @@ pkgname+=('systemd-common' 'systemd-udev')
# We split Arch's systemd-libs into systemd-$X, for the following $X:
_systemd_libs=('libsystemd' 'libudev' 'nss-systemd' 'nss-myhostname' 'nss-mymachines' 'nss-resolve')
pkgname+=("${_systemd_libs[@]/#/systemd-}")
-# Can be from either systemd or systemd-stable
-_commit='e51d9bf9e5ac5a6618c175cd9b5cfdc6733cd5d1'
-pkgver=243.162
-pkgrel=2
+_tag='50a79652baa8650dc2bf7fe5979e67eb673a218e' # git rev-parse v${pkgver}
+pkgver=244.1
+pkgrel=1
pkgrel+=.parabola1
arch=('x86_64')
arch+=('i686' 'armv7h' 'ppc64le')
@@ -30,8 +29,7 @@ makedepends_x86_64=('gnu-efi-libs')
options=('strip')
validpgpkeys=('63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering <lennart@poettering.net>
'5C251B5FC54EB2F80F407AAAC54CA336CFEB557E') # Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>
-source=(# fragment is latest tag for source verification, final merge in prepare()
- "git+https://github.com/systemd/systemd-stable#tag=v${pkgver%.*}?signed"
+source=("git+https://github.com/systemd/systemd-stable#tag=${_tag}?signed"
"git+https://github.com/systemd/systemd#tag=v${pkgver%.*}?signed"
'0001-Use-Arch-Linux-device-access-groups.patch'
'initcpio-hook-udev'
@@ -61,7 +59,7 @@ source=(# fragment is latest tag for source verification, final merge in prepare
'0007-FSDG-bootctl-Say-Systemd-Boot-Manager-instead-of-Lin.patch')
sha512sums=('SKIP'
'SKIP'
- '9348683829190628e25b7b3300fd880c426d555bde330d5fc5150a9a54b3ad9d4d1f2e69ea1dc6d6f086693dacc53c5af30f1fa7ad9b479791fd77bcdafa430e'
+ 'e38c7c422c82953f9c2476a5ab8009d614cbec839e4088bff5db7698ddc84e3d8ed64f32ed323f57b1913c5c9703546f794996cb415ed7cdda930b627962a3c4'
'f0d933e8c6064ed830dec54049b0a01e27be87203208f6ae982f10fb4eddc7258cb2919d594cbfb9a33e74c3510cfd682f3416ba8e804387ab87d1a217eb4b73'
'01de24951a05d38eca6b615a7645beb3677ca0e0f87638d133649f6dc14dcd2ea82594a60b793c31b14493a286d1d11a0d25617f54dbfa02be237652c8faa691'
'a25b28af2e8c516c3a2eec4e64b8c7f70c21f974af4a955a4a9d45fd3e3ff0d2a98b4419fe425d47152d5acae77d64e69d8d014a7209524b75a81b0edb10bf3a'
@@ -80,12 +78,12 @@ sha512sums=('SKIP'
'577e33a1c50b4b41157a67f64162b035dd0c4a541e19cee55a100048bdb50cb2c82852741b1372989a0fe4c4782ba477522747fcc81d72aed99b3db512a86447'
'c4463fdd25e14a836ac3b874109861a55a0169c4206b6356b53974dd4621f645652087ebf4c738b18734a718fe7fd9ec6b700ce8dd9736525274eb16b10385e6'
'209b01b044877cc986757fa4009a92ea98f480306c2530075d153203c3cd2b3afccab6aacc1453dee8857991e04270572f1700310705d7a0f4d5bed27fab8c67'
- '83a00469c63f9cdb069264209e545bddce0abc0024339bbc271d8ecb249fdabb984c0f4e4ab52d84e8ec03d2c6d9b3106f3d880c218d806cbe7a76a74c4d0908'
+ '2224afc1b69dbfa0818943a96bc878a7dffbd12a585d9c6417089e32aa5498a95bda6623608449887eab7e67f516dfd344fb1704f1f579e6467212278453a1f2'
'f8ad54b5fcc8c4e37fbcd364bbf5eafced8db3f2a362ed29b04e1ff67001cedbd4f91cc0e4a9ae143be8d1191902bcc35a48a624ffd45ed1a4bd57df389d4cc4'
'fd0df3d365892d4d461a78bb0b728201e81c1269af07a38e134fadfc0ffb29aade7642142d128abcf88803b86494d7629ff5990359ef067feea3d476c7238a67'
'e9e884015a40dc796fd8cbd8f79b3b9eebc7e48a332b22d52104c21c492be9982b35b7dd30bc29f2c2d274707ffd043eda059659844a4cd50eb433b8a3f7648c'
'0d6b894149ec8d0612d1be1dee5daa1768345232e450435ddc750e36a8309dd96782a92f0220169c69103b1c4632af708e4a737cb7ba817944c92dcb61379a30'
- '89af420d0e91c370c7f4b495bdbf5e506615327cce320deaa730d79646a3747b56708bae2bbe2a2e34a2d24e85ae817d5be11aeafa4b62cd8d6264088d790af5'
+ '8e9147034e979eada4da6e4af9a9e11ef985b1a4493d70d4a3db6476e7699ab84cb16fad0c4d0ce37ac34686950ecb747e142da7b3182aaebb704bdec2473dbf'
'28a5b3fc9e2c5cec9267bb96725c73ee77788514f140c0cf8df765af64bc8130dd02f4863d9128ac45d54256b2ab4f2b06d1a3f65660ce1dfba5727618cd1839')
_backports=(
@@ -99,9 +97,6 @@ prepare() {
# add upstream repository for cherry-picking
git remote add -f upstream ../systemd
- # merge the latest stable commit (fast-foward only to make sure
- # the verified tag is in)
- git merge --ff-only "${_commit}"
local _c
for _c in "${_backports[@]}"; do
@@ -123,17 +118,6 @@ prepare() {
done
}
-pkgver() {
- cd "$pkgbase-stable"
-
- # TODO: Switch to upstream versioning post v243!
-
- local _version _count
- _version='v243'
- _count="$(git rev-list --count ${_version}..)"
- printf '%s.%s' "${_version#v}" "${_count}"
-}
-
build() {
local _timeservers=({0..3}.arch.pool.ntp.org)
local _nameservers=(
@@ -166,9 +150,10 @@ build() {
-Ddbuspolicydir=/usr/share/dbus-1/system.d
-Ddefault-hierarchy=hybrid
- -Ddefault-locale=C
-Ddefault-kill-user-processes=false
+ -Ddefault-locale=C
-Dfallback-hostname='parabola'
+ -Dnologin-path=/usr/bin/nologin
-Dntp-servers="${_timeservers[*]}"
-Ddns-servers="${_nameservers[*]}"
-Drpmmacrosdir=no