summaryrefslogtreecommitdiff
path: root/libre/sagemath/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/sagemath/PKGBUILD')
-rw-r--r--libre/sagemath/PKGBUILD40
1 files changed, 22 insertions, 18 deletions
diff --git a/libre/sagemath/PKGBUILD b/libre/sagemath/PKGBUILD
index 2afee391c..29182aed8 100644
--- a/libre/sagemath/PKGBUILD
+++ b/libre/sagemath/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 207027 2017-01-12 16:53:13Z arojas $
+# $Id: PKGBUILD 207932 2017-01-18 22:19:45Z arojas $
# Maintainer (Arch): Evgeniy Alekseev <arcanis.arch at gmail dot com>
# Maintainer (Arch): Antonio Rojas <arojas@archlinux.org>
# Contributor (Arch): Daniel Wallace <danielwallace at gtmanfred dot com>
@@ -10,7 +10,7 @@
# Maintainer: André Silva <emulatorman@parabola.nu>
pkgname=sagemath
-pkgver=7.5
+pkgver=7.5.1
pkgrel=2.parabola1
pkgdesc="Free Mathematics Software, free software replacement of Magma, Maple, Mathematica, and Matlab, without nonfree nauty support"
arch=(i686 x86_64 armv7h)
@@ -29,27 +29,29 @@ optdepends=('cython2: to compile cython code' 'python2-pkgconfig: to compile cyt
'coxeter3: Coxeter groups implementation' 'cryptominisat2: SAT solver' 'gap-data: for computing Galois groups'
'lrs: Algorithms for linear reverse search used in game theory and for computing volume of polytopes'
'libhomfly: for computing the homfly polynomial of links' 'libbraiding: for computing in braid groups'
+ 'python2-pynormaliz: Normaliz backend for polyhedral computations'
'sagemath-jupyter: Jupyter kernel')
-makedepends=(cython2 boost ratpoints symmetrica fflas-ffpack python2-jinja coin-or-cbc libhomfly libbraiding
+makedepends=(cython2 boost ratpoints symmetrica python2-jinja coin-or-cbc libhomfly libbraiding
mcqd coxeter3 cryptominisat2 modular_decomposition bliss-graphs tdlib python2-pkgconfig meataxe) # libfes
conflicts=(sage-mathematics)
replaces=(sage-mathematics)
provides=(sage-mathematics)
source=("$pkgname-$pkgver.tar.gz::https://github.com/sagemath/sage/archive/$pkgver.tar.gz"
env.patch skip-check.patch cython-sys-path.patch is-package-installed.patch package.patch disable-fes.patch
- jupyter-path.patch test-optional.patch ecm-7.patch increase-rtol.patch sagemath-gslcblas.patch)
-md5sums=('bff1fb8793ebc2934d14cf1efdcfbea3'
- '70b7c1c5da6400e1ae48cf1e5a2d2879'
- '6cafcb381437d4751fd55b25d5090987'
- '0de8f29a99a48e2ca2a13045f122c386'
- '409b0a2c520eb33281b5f262afcb6c76'
- 'ccfd5b1bc4796f414f1531be52504dd7'
- '06a67e611d10aa2381efe1f08ea4ffd9'
- '0d88207416dfb98a17bf8886257d9a02'
- '921017fd2d9dadbb6b602ac0476bfd58'
- '0c9a57d35de80c2cd418ebec912efbbb'
- '39d3fded716d2a7ae0ab03e0896b7497'
- 'a3ca7c861c19eb1c605a43641cb6923f')
+ jupyter-path.patch test-optional.patch ecm-7.patch increase-rtol.patch sagemath-gslcblas.patch r-no-readline.patch)
+sha256sums=('3cd9af3e3bfd7f5cc966b7c36168d04b9a1213aa9a7af3286b5d53d40e7653e3'
+ '9dba04ff13626a7b6c338a8b18a6c27d343f68a547a218533cf773af3dae6635'
+ 'b02b3d2d5620ca20f96adb62b6fef05e4676c0a60983310a1450fdf3d923cb04'
+ 'ff7e034d08ab084fdb193484f7fe3a659ebcd8ab33a2b7177237d65b26de7872'
+ 'd60fb0fbd27991ce9496ca035a54b03334b5b53f244227a8d6e13f3327ce75d2'
+ '4a2297e4d9d28f0b3a1f58e1b463e332affcb109eafde44837b1657e309c8212'
+ '7ab53d30b877dabb6835fbe67a208bef65fa0aaf40221b4d0b58e4b7086bc47a'
+ '775051aa9076ebf631c8a291af38b6ec4a13c904740dc9da831641d592d8bcd8'
+ '81d08c6a760f171f3381455b66a6c84789c9f0eefddbe6ca5794075514ad8c3a'
+ '65ad84c83d5f956fde8eab961f2caad56d64044324c4abc0e56bcd9f44061cb6'
+ 'be925eefeac3f28e639794ddc20d64e6faafd7181804e29417a510224d19ccc7'
+ '973224f53e9a6fcfaa9c6cb842b02430a601d1c7ce0abb41b3591470d128930c'
+ 'ef9f401fa84fe1772af9efee6816643534f2896da4c23b809937b19771bdfbbf')
prepare(){
cd sage-$pkgver
@@ -71,6 +73,10 @@ prepare(){
patch -p1 -i ../ecm-7.patch
# increase numerical tolerance, needed by scipy 0.18
patch -p1 -i ../increase-rtol.patch
+# fix cblas linking in gsl modules
+ patch -p1 -i ../sagemath-gslcblas.patch
+# fix freezes in R interface with readline 7 (Debian)
+ patch -p1 -i ../r-no-readline.patch
# Upstream patches
# fix build against libfes 0.2 http://trac.sagemath.org/ticket/15209
@@ -79,8 +85,6 @@ prepare(){
patch -p0 -i ../disable-fes.patch
# replace is_package_installed usage http://trac.sagemath.org/ticket/20377
patch -p1 -i ../is-package-installed.patch
-# don't remove gslcblas from gsl libraries https://trac.sagemath.org/ticket/22085
- patch -p1 -i ../sagemath-gslcblas.patch
# use python2
sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' -e 's|exec python|exec python2|' -i src/bin/*