summaryrefslogtreecommitdiff
path: root/libre/ruby/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/ruby/PKGBUILD')
-rw-r--r--libre/ruby/PKGBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/libre/ruby/PKGBUILD b/libre/ruby/PKGBUILD
index 002a67eaa..772bea4fa 100644
--- a/libre/ruby/PKGBUILD
+++ b/libre/ruby/PKGBUILD
@@ -7,6 +7,7 @@
# Contributor: Daniel Milewski <niitotantei@riseup.net>
# Contributor: André Silva <emulatorman@hyperbola.info>
# Contributor: Luke Shumaker <lukeshu@parabola.nu>
+# Contributor: Omar Vega Ramos <ovruni@gnu.org.pe>
# Rationale for inclusion in [libre]: Problematic license of
# generator.c in bundled json extension.
@@ -16,10 +17,10 @@
# https://github.com/flori/json/issues/277
pkgname=(ruby ruby-docs)
-pkgver=2.4.1
-_jsonver=2.0.2
-pkgrel=3.parabola3
-_srcrel=2 # increment this to rebuild the sourceball without bumping pkgver
+pkgver=2.5.0
+_jsonver=2.1.0
+pkgrel=1.parabola1
+_srcrel=1 # increment this to rebuild the sourceball without bumping pkgver
arch=(i686 x86_64 armv7h)
url='http://www.ruby-lang.org/en/'
license=(BSD2 custom)
@@ -27,28 +28,24 @@ makedepends=(gdbm openssl libffi doxygen graphviz libyaml ttf-dejavu tk)
options=(!emptydirs)
source=(https://repo.parabola.nu/other/ruby-libre/ruby-${pkgver}-libre${_srcrel}.tar.gz
gemrc)
-sha1sums=('ca7ca50c2e96200062afe081bf82c2cfaa3d18a1'
- 'dc536754c8fac2c3d82965c5a708cd8f79562d98')
+sha512sums=('e94355d3d9b6882f4dc355ca6721a0ce1b777f7f1144144adfa2e5732acbfb69f16b062ce9fad5be0e2e06ac49db0171d9e9fcc43c78836b5bbf3a5b97ef145e'
+ '8cafd14d414ee3c16aa94f79072bc6c100262f925dc1300e785846c3fabbbbffc1356b8e2223af5684e3340c55032d41231179ffa948bb12e01dbae0f4131911')
mkdepends=('ruby') # for 'gem build'
mksource=(https://cache.ruby-lang.org/pub/ruby/${pkgver:0:3}/ruby-${pkgver}.tar.xz
ruby-${pkgver}-remove-json-ext.patch
ruby-${pkgver}-add-json_pure.patch
json-${_jsonver}.tar.gz::https://github.com/flori/json/archive/v${_jsonver}.tar.gz
- json-${_jsonver}-ruby-${pkgver}-backports.patch
json-${_jsonver}-libre.patch)
-mksha512sums=('e6fd290b6edd166348b70f0f1c56f7ed9d956c4c1eb91d97d0548041ca4196b9b75ec1ad35c745bdbfd4de195899093e7205d7f02b014ecf1c48e6f31cf25903'
- 'a7b6a5a6da4861ee51f3e9a9064c39ef1e5f2efb7d969f20f93028acfa0eed0264c336fce2eb1c6a3bdcdc595ef2cf3441b5db7cd4eebf5f24e5cb4a19a7d915'
- '29185acc7ea3ad48e805945e53717bfd8483a0581236eb49e63eb8e9f467ddcede38a606d089aa35e5fb73099a1ebdb253fc4c51a7933b900fc36918a43628b8'
- '405f09681808c108ec4a889f7628ede4aec15122c8a6848b5a7ec99a17bd8d72bf410152461164acd0f17d92a460732bf525c26a17b319b94dc940dccf6d3ebf'
- '1882619e98fa4b6cc2738c25ebf0ba957499f6b20f6837f23379b90700a6a751d0a9be85032f1c9e1d98f8d839784a3caa611266ad68e311dd3747cb0396b817'
- '53459f8971e87a3a5dfff3e72be5d27460a624eff06ccabb57bef1fd039c77d67f0f9eecdc03661c929d9eda9bff8f86383c9b16b15602a874bcf1914aecf633')
+mksha512sums=('55714a33d7661fe8b432f73c34fd67b49699f8b79df1cbd680a74899124d31111ab0f444677672aac1ba725820182940d485efb2db0bf2bc96737c5d40c54578'
+ 'dbfd2517e87571e25fea832f50535e76c07972e15f48050ad7b08b04993c566ae7b5e8b1dd0e3cd65eb6161290026eaa71ff4528e98a92e37983066b4929cfb1'
+ '303172561a4ba54515fddfd9ea7e0c833e550b0ae5e9f331956f178f8c5e20aa0e3c4036251ddfd04312769ef7d71d83fde0afe64f6fa8e9052ca5a294c62927'
+ '6019cc26a0919e4d39ae0bf737b51cd9a474c74a55d25f6931ac04d61826bb810d063190a80a29810e57d7457d1a247acd82fd78de2c4c01acb7d73ee9fde603'
+ 'ccbcbc964e08c10470f1552cec5bcf71fc14f4f6faf83e51fcaf01b662596f5400e7f60279209c9d4df03e3c798b9008383667375f884a1115ac96956053a38d')
mksource() {
# Start with the vanilla version of json
cd "$srcdir/json-${_jsonver}"
- # Apply changes made to it for the ruby distribution
- patch -p1 -i ../json-${_jsonver}-ruby-${pkgver}-backports.patch
# Modify it so that 'json' doesn't try to load (non-free!) 'json/ext'
rm -rf -- json.gemspec ext lib/json/ext*
patch -p1 -i ../json-${_jsonver}-libre.patch