summaryrefslogtreecommitdiff
path: root/libre/riscv32-elf-newlib/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/riscv32-elf-newlib/PKGBUILD')
-rw-r--r--libre/riscv32-elf-newlib/PKGBUILD41
1 files changed, 0 insertions, 41 deletions
diff --git a/libre/riscv32-elf-newlib/PKGBUILD b/libre/riscv32-elf-newlib/PKGBUILD
deleted file mode 100644
index c05277391..000000000
--- a/libre/riscv32-elf-newlib/PKGBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Maintainer: David P. <megver83@parabola.nu>
-
-_target=riscv32-elf
-pkgname=$_target-newlib
-pkgver=3.1.0
-pkgrel=2
-_upstream_ver=$pkgver
-pkgdesc='A C standard library implementation intended for use on embedded systems (RISC V 32)'
-arch=(any)
-url='http://www.sourceware.org/newlib/'
-license=(BSD)
-makedepends=($_target-gcc-initial)
-options=(!emptydirs !strip)
-source=(ftp://sourceware.org/pub/newlib/newlib-$_upstream_ver.tar.gz)
-sha256sums=('fb4fa1cc21e9060719208300a61420e4089d6de6ef59cf533b57fe74801d102a')
-
-build() {
- mkdir newlib-build
-
- export CFLAGS_FOR_TARGET='-g -O2 -ffunction-sections -fdata-sections'
- cd "$srcdir"/newlib-build
- ../newlib-$_upstream_ver/configure \
- --target=$_target \
- --prefix=/usr \
- --disable-newlib-supplied-syscalls \
- --disable-nls \
- --enable-newlib-io-long-long \
- --enable-newlib-register-fini
- make
-
-}
-
-package() {
- cd "$srcdir"/newlib-build
- make DESTDIR="$pkgdir" install -j1
-
- find "$pkgdir"/usr/$_target/lib \( -name "*.a" -or -name "*.o" \) -exec $_target-objcopy -R .comment -R .note -R .debug_info -R .debug_aranges -R .debug_pubnames -R .debug_pubtypes -R .debug_abbrev -R .debug_line -R .debug_str -R .debug_ranges -R .debug_loc '{}' \;
-
- install -d "$pkgdir"/usr/share/licenses/$pkgname/
- install -m644 -t "$pkgdir"/usr/share/licenses/$pkgname/ "$srcdir"/newlib-$_upstream_ver/COPYING*
-}