summaryrefslogtreecommitdiff
path: root/libre/qtcreator/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/qtcreator/PKGBUILD')
-rw-r--r--libre/qtcreator/PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/libre/qtcreator/PKGBUILD b/libre/qtcreator/PKGBUILD
index 093e85b93..f76221351 100644
--- a/libre/qtcreator/PKGBUILD
+++ b/libre/qtcreator/PKGBUILD
@@ -8,15 +8,19 @@
# Contributor (Arch): delor <bartekpiech gmail com>
# Contributor: André Silva <emulatorman@hyperbola.info>
+# parabola changes and rationale:
+# - removed support for qt5-webengine
+# - added patch to build on arm
+
pkgname=qtcreator
pkgver=4.5.0
_clangver=5.0.1
-pkgrel=2.parabola1
+pkgrel=2.parabola2
pkgdesc='Lightweight, cross-platform integrated development environment, without nonfree qt5-webengine support'
arch=(x86_64 i686 armv7h)
url='http://qt-project.org'
license=(LGPL)
-depends=(qt5-tools qt5-declarative qt5-script qt5-quickcontrols qt5-quickcontrols2 clang=$_clangver qbs)
+depends=(qt5-tools qt5-quickcontrols qt5-quickcontrols2 clang=$_clangver qbs)
makedepends=(git mesa llvm)
options=(docs)
optdepends=('qt5-doc: integrated Qt documentation'
@@ -30,8 +34,10 @@ optdepends=('qt5-doc: integrated Qt documentation'
'bzr: bazaar support'
'valgrind: analyze support')
source=("http://download.qt.io/official_releases/qtcreator/${pkgver%.*}/${pkgver}/qt-creator-opensource-src-${pkgver}.tar.xz"
+ '0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch'
'libre.patch')
sha512sums=('9296ebef4a3d5ae40a9fa3a4039e77b8e407dfb52af3a88b4cc615a89e163d92de420d9db614bc689adc695879f0c2e1906e9a218e7a6b96c4b222d52c94912c'
+ 'af0a0d5a2fadcfce14def65be73c99bff8227794b9ad2be333713c89e226e2c6b43802a802b6e30f3e6c1b4b77f31183bffdcca3404d9686f15fa84dfc64d1a1'
'a1be1d669e1a496ab8e975b925e4b2fa962fc268616deffa09163c42d62874adf210e47cd16ee375110ef53791bd84d53d115b422cef49ba98efbd552e99944c')
prepare() {
@@ -46,6 +52,9 @@ prepare() {
cd qt-creator-opensource-src-${pkgver}
patch -Np1 -i "$srcdir"/libre.patch
rm -rv src/plugins/help/webenginehelpviewer.{cpp,h}
+ if [[ "$CARCH" == arm* ]]; then
+ git apply ../0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch
+ fi
}
build() {