summaryrefslogtreecommitdiff
path: root/libre/qt5-webengine/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/qt5-webengine/PKGBUILD')
-rw-r--r--libre/qt5-webengine/PKGBUILD74
1 files changed, 0 insertions, 74 deletions
diff --git a/libre/qt5-webengine/PKGBUILD b/libre/qt5-webengine/PKGBUILD
deleted file mode 100644
index b06bfdc38..000000000
--- a/libre/qt5-webengine/PKGBUILD
+++ /dev/null
@@ -1,74 +0,0 @@
-# $Id: PKGBUILD 240297 2015-06-03 10:22:03Z fyan $
-# Maintainer (Arch): Felix Yan <felixonmars@archlinux.org>
-# Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
-# Maintainer: André Silva <emulatorman@parabola.nu>
-# Contributor: Luke R. <g4jc@openmailbox.org>
-# Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
-
-pkgname=qt5-webengine
-_qtver=5.8.0
-pkgver=${_qtver/-/}
-pkgrel=3.parabola1
-arch=('i686' 'x86_64' 'armv7h')
-url='http://qt-project.org/'
-license=('LGPL3' 'LGPL2.1' 'BSD')
-pkgdesc='Provides support for web applications using the Chromium browser project, without nonfree codecs'
-depends=('qt5-webchannel' 'qt5-location' 'libxcomposite' 'libxrandr' 'pciutils' 'libxss' 'libvpx'
- 'libevent' 'libsrtp' 'snappy' 'nss' 'protobuf' 'libxslt' 'libxdamage' 'minizip' 'ffmpeg')
-makedepends=('python2' 'git' 'gperf' 'jsoncpp')
-groups=('qt' 'qt5')
-_pkgfqn="${pkgname/5-/}-opensource-src-${_qtver}"
-source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz" qt5-webengine-nss.patch
- qtwebengine-5.7.0-icu58.patch
- qtbug-58488.patch::"https://github.com/qt/qtwebengine/commit/7e7dd262.patch"
- qtwebengine-opensource-src-5.6.0-beta-no-neon.patch
- system-ffmpeg.patch)
-
-md5sums=('6e7fb2be161c6db4d988a4f5b329672f'
- '2a1610b34204102938a24154a52e5571'
- '9d225d1bf83ea45dbf6556d30d35fcb8'
- '3762cbdbc6a752e4d876e048e5e16de6'
- '123d4d0d7db7473649ff2b5650330cc4'
- '9f79b14f7c5ff603c1fcd87f37a8904f')
-
-prepare() {
- mkdir -p build
-
- # Hack to force using python2
- mkdir -p bin
- ln -s /usr/bin/python2 bin/python
-
- # Fix opening some websites with recent NSS https://github.com/QupZilla/qupzilla/issues/1870 (KaOSx patch)
- cd ${_pkgfqn}
- # patch -p1 -i ../qt5-webengine-nss.patch
-
- # Fix build with ICU 58 (gentoo)
- patch -p1 -i "$srcdir"/qtwebengine-5.7.0-icu58.patch
-
- # Prevent drop-down popups form stealing focus https://bugreports.qt.io/browse/QTBUG-58488
- patch -p1 -i ../qtbug-58488.patch
-
- if [[ $CARCH == "armv7h" ]]; then
- patch -p0 -i ../qtwebengine-opensource-src-5.6.0-beta-no-neon.patch
- patch -p1 -i ../system-ffmpeg.patch
- fi
-}
-
-build() {
- cd build
-
- export PATH="$srcdir/bin:$PATH"
- qmake WEBENGINE_CONFIG+="use_system_ffmpeg use_system_icu" ../${_pkgfqn}
- make
-}
-
-package() {
- cd build
- make INSTALL_ROOT="$pkgdir" install
-
- # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
- find "$pkgdir/usr/lib" -type f -name '*.prl' \
- -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
-
- install -Dm644 "$srcdir"/${_pkgfqn}/src/3rdparty/chromium/LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE.chromium
-}