summaryrefslogtreecommitdiff
path: root/libre/qemu-user-static/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/qemu-user-static/PKGBUILD')
-rw-r--r--libre/qemu-user-static/PKGBUILD67
1 files changed, 21 insertions, 46 deletions
diff --git a/libre/qemu-user-static/PKGBUILD b/libre/qemu-user-static/PKGBUILD
index a3030470b..5080f5f7b 100644
--- a/libre/qemu-user-static/PKGBUILD
+++ b/libre/qemu-user-static/PKGBUILD
@@ -3,41 +3,34 @@
# Maintainer: Luke Shumaker <lukeshu@parabola.nu>
# Contributor: Márcio Silva <coadde@hyperbola.info>
+# "Do I need to rebuild?" : A flowchart
+#
+# ,--> pixman-static ------------------------------------,
+# | 0.34.0-1.static2 |
+# qemu-user-static --+------------------------+----> pcre-static -----------+--> glibc
+# 2.12.0-1.static1 | | 8.42-1.static1 | 2.27-3
+# `--> glib2-static -------+----> libffi-static ---------+
+# 2.56.1-1.static1 | 3.2.1-2.static2 |
+# +----> libutil-linux-static --+
+# | 2.32-3.static1 |
+# `----> zlib ------------------'
+# 1:1.2.11-2
+
_pkgbase=qemu
pkgname=(qemu-user-static qemu-user-static-binfmt)
pkgdesc="A generic and open source machine emulator and virtualizer"
-pkgver=2.11.0
-pkgrel=3.parabola1
+pkgver=2.12.0
+pkgrel=1.static1
arch=(x86_64)
arch+=(i686 armv7h)
license=(GPL2 LGPL2.1)
url="http://wiki.qemu.org/"
makedepends=(pixman-static glib2-static pcre-static python2)
-source=("$url/download/${_pkgbase}-${pkgver}.tar.bz2"{,.sig}
- 0001-linux-user-Use-if-to-only-call-validate_guest_space-.patch
- 0002-linux-user-Rename-validate_guest_space-init_guest_co.patch
- 0003-linux-user-init_guest_space-Clean-up-if-we-can-t-ini.patch
- 0004-linux-user-init_guest_space-Correctly-handle-guest_s.patch
- 0005-linux-user-init_guest_space-Clarify-page-alignment-l.patch
- 0006-linux-user-init_guest_commpage-Add-a-comment-about-s.patch
- 0007-linux-user-init_guest_space-Clean-up-control-flow-a-.patch
- 0008-linux-user-init_guest_space-Don-t-try-to-align-if-we.patch
- 0009-linux-user-init_guest_space-Add-a-comment-about-sear.patch
- 0010-linux-user-init_guest_space-Try-to-make-ARM-space-co.patch
+source=(https://download.qemu.org/qemu-$pkgver.tar.xz{,.sig}
allow_elf64.patch)
-sha256sums=('c4f034c7665a84a1c3be72c8da37f3c31ec063475699df062ab646d8b2e17fcb'
+sha256sums=('e69301f361ff65bf5dabd8a19196aeaa5613c1b5ae1678f0823bdf50e7d5c6fc'
'SKIP'
- '9953a8debd9456adb4f5968817fa89da4d4542e44980a5533ccf86371d819845'
- 'a977e9295daa14a9c73258cf16399eb5af66382217f8a4e69951ec044131a7ce'
- 'dba2cfeb24841d45936091319957ee6f65e481da3c761791d410d3b8e6799998'
- '75b3bda6752c4bf17488489f898767b6772b10ecc5d1f0a5bc1bd831e99a31e3'
- '731895a8ed6f6d322bb60764b01cf09e0ea762d7d53fc01e91c2d2aecfdc8844'
- '69b37040f52ef86b86c7c2952eb3f85f3c67d7adf289c43fdac8c71827c6e5b9'
- '76f88850b0f52450eecb80029ffe16db6f418cec3b58231aca354cc20bbfb16a'
- '76944d84990cc76e47c381849c683a346c5234bcebbe4c24334d0fd8368482db'
- '7845867348fd380def28c7fe023e54cee8ff88cd6754aae3ab3472149cfbde51'
- '1953e7cac58c23526d007d8559410e0042d4a7c1b8cbd5f4c0543f7f876436dd'
- '13a6d9e678bdc9e1f051006cfd0555f5a80582368f54c8a1bb5a78ece3832ac4')
+ '59751f1ed26ea61b2a37ebee4be6979e584a450b611282138a0893aa9173e2e4')
validpgpkeys=('CEACC9E15534EBABB82D3FA03353C9CEF108B584')
case $CARCH in
@@ -52,13 +45,6 @@ prepare() {
cd ${_pkgbase}-${pkgver}
sed -i 's/vte-2\.90/vte-2.91/g' configure
- # https://bugs.launchpad.net/qemu/+bug/1740219
- # https://lists.nongnu.org/archive/html/qemu-devel/2017-12/msg05237.html
- local patchfile
- for patchfile in ../????-linux-user-*.patch; do
- patch -p1 < "$patchfile"
- done
-
patch -p1 < ../allow_elf64.patch
}
@@ -124,7 +110,7 @@ package_qemu-user-static() {
replaces=(qemu-static)
conflicts=(qemu-static)
- _package static
+ make -C build-static DESTDIR="$pkgdir" install "${@:2}"
rm -vr -- \
"$pkgdir"/usr/lib/ \
@@ -136,15 +122,6 @@ package_qemu-user-static() {
done
}
-_package() {
- options=(!strip)
-
- make -C build-$1 DESTDIR="$pkgdir" install "${@:2}"
-
- cd "$pkgdir"/usr/bin
- tidy_strip
-}
-
package_qemu-user-static-binfmt() {
pkgdesc="binfmt registration for QEMU user-mode emulation"
depends=("qemu-user-static=$pkgver")
@@ -157,11 +134,9 @@ package_qemu-user-static-binfmt() {
install -d "$pkgdir"/usr/lib/binfmt.d
- < scripts/qemu-binfmt-conf.sh \
- sed -e 's/^CHECK=.*/CHECK=qemu_check_systemd/' \
- -e 's/^BINFMT_SET=.*/BINFMT_SET=qemu_generate_systemd/' \
- | sh /dev/stdin \
+ ./scripts/qemu-binfmt-conf.sh \
--qemu-path /usr/bin \
+ --systemd ALL \
--exportdir "$pkgdir"/usr/lib/binfmt.d \
--credential yes