summaryrefslogtreecommitdiff
path: root/libre/pyqt5/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/pyqt5/PKGBUILD')
-rw-r--r--libre/pyqt5/PKGBUILD115
1 files changed, 10 insertions, 105 deletions
diff --git a/libre/pyqt5/PKGBUILD b/libre/pyqt5/PKGBUILD
index bbd909b82..e1a5105cb 100644
--- a/libre/pyqt5/PKGBUILD
+++ b/libre/pyqt5/PKGBUILD
@@ -1,4 +1,3 @@
-# $Id: PKGBUILD 291120 2017-03-20 15:54:10Z arojas $
# Maintainer (Arch): Felix Yan <felixonmars@archlinux.org>
# Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
# Contributor (Arch): Yichao Yu <yyc1992@gmail.com>
@@ -7,50 +6,28 @@
# Maintainer: André Silva <emulatorman@hyperbola.info>
# Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
-# Rationale: build without support for nonfree qt5-webengine.
-#
-# Differences between extra/pyqt5 and this:
-# - We a apply opengles-hack.patch on ARM
+# parabola changes and rationale:
# - We don't list qt5-webengine as a dependency. The configure
# script will pick up on it not being there, and automatically
# disable that module.
-# - We apply a patch to the configure to make it print which modules
-# it decides to enable/disable, so the package maintainer can tell
-# if something went wrong earlier.
pkgbase=pyqt5
pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
-pkgver=5.11.2
-pkgrel=2.parabola3
-arch=('i686' 'x86_64' 'armv7h')
+pkgver=5.11.3
+pkgrel=1
+pkgrel+=.par1
+arch=('x86_64')
+arch+=('i686' 'armv7h')
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
license=('GPL')
makedepends=('python-sip-pyqt5' 'python2-sip-pyqt5' 'sip' 'python-opengl' 'python2-opengl' 'python2-enum34'
'python2-dbus' 'python-dbus' 'qt5-connectivity' 'qt5-multimedia' 'qt5-tools' 'qt5-serialport' 'qt5-svg'
'qt5-webkit' 'qt5-websockets' 'qt5-x11extras' 'qt5-networkauth')
-source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz"
- 'pyqt5-verbose-configure.patch'
- 'opengles-hack.patch')
-sha512sums=('fc60246b5e1ca0d8aeef829fe20de9dd28b77e3c151532f9dbcd92c0deec12d8308cc799901aeec3f84af745e735053d2aaad2866ef64a2426cba343e08bc2c0'
- '139780a2a105605684e8e13b967b8bf8738e6ea0e7793179600c628a179695e4b05952da6d60e67ffac56857afdb08a976896e0ae25a9dbf40085b7fe39f9283'
- '6be0458a53dc96919d2dfe7a3e932ac663e6e9ebcc2516809f8c53ad923566bf3f96f622ee52ee8a97bf1bea2fc72f78e60333daa6bb3555ff3ca8371141f2b7')
+source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz")
+sha512sums=('6f4abb1866ce357263c208121607072e127c8853e9c6bf039b034fefdda4c40e38f917c3b313375f0d692d764ecf26ff3a6b12cda2a2eeb5237db8b5e9443548')
prepare() {
- pushd PyQt5_gpl-$pkgver
-
- case "$CARCH" in
- armv7h) patch -p1 -i ../opengles-hack.patch;;
- esac
-# patch -p1 -i ../pyqt5-verbose-configure.patch
- popd
-
-
- # The additional include path was removed due to this line, I don't really know why they are doing this...
- sed -i '/target_config.dbus_inc_dirs = \[\]/d' PyQt5_gpl-$pkgver/configure.py
-
cp -a PyQt5_gpl-$pkgver{,-py2}
-# Remove check for sip from py2, it doesn't work since sip doesn't install __init__.py
- sed -e 's|from PyQt5 import sip|pass|g' -i PyQt5_gpl-$pkgver-py2/configure.py
}
build() {
@@ -58,86 +35,14 @@ build() {
python configure.py \
--confirm-license \
--no-sip-files \
- --no-dist-info \
- --qsci-api \
- --verbose \
- --enable QtBluetooth \
- --enable QtCore \
- --enable QtDBus \
- --enable QtDesigner \
- --enable QtGui \
- --enable QtHelp \
- --enable QtLocation \
- --enable QtMultimedia \
- --enable QtMultimediaWidgets \
- --enable QtNetwork \
- --enable QtNfc \
- --enable QtOpenGL \
- --enable QtPositioning \
- --enable QtPrintSupport \
- --enable QtQml \
- --enable QtQuick \
- --enable QtQuickWidgets \
- --enable QtSensors \
- --enable QtSerialPort \
- --enable QtSql \
- --enable QtSvg \
- --enable QtTest \
- --enable QtWebChannel \
- --enable QtWebKit \
- --enable QtWebKitWidgets \
- --enable QtWebSockets \
- --enable QtWidgets \
- --enable QtX11Extras \
- --enable QtXml \
- --enable QtXmlPatterns \
- --enable _QOpenGLFunctions_2_0 \
- --enable _QOpenGLFunctions_2_1 \
- --enable _QOpenGLFunctions_4_1_Core
-
+ --qsci-api
make
cd "$srcdir"/PyQt5_gpl-$pkgver-py2
python2 configure.py \
--confirm-license \
--no-sip-files \
- --no-dist-info \
- --qsci-api \
- --verbose \
- --enable QtBluetooth \
- --enable QtCore \
- --enable QtDBus \
- --enable QtDesigner \
- --enable QtGui \
- --enable QtHelp \
- --enable QtLocation \
- --enable QtMultimedia \
- --enable QtMultimediaWidgets \
- --enable QtNetwork \
- --enable QtNfc \
- --enable QtOpenGL \
- --enable QtPositioning \
- --enable QtPrintSupport \
- --enable QtQml \
- --enable QtQuick \
- --enable QtQuickWidgets \
- --enable QtSensors \
- --enable QtSerialPort \
- --enable QtSql \
- --enable QtSvg \
- --enable QtTest \
- --enable QtWebChannel \
- --enable QtWebKit \
- --enable QtWebKitWidgets \
- --enable QtWebSockets \
- --enable QtWidgets \
- --enable QtX11Extras \
- --enable QtXml \
- --enable QtXmlPatterns \
- --enable _QOpenGLFunctions_2_0 \
- --enable _QOpenGLFunctions_2_1 \
- --enable _QOpenGLFunctions_4_1_Core
-
+ --qsci-api
make
}