summaryrefslogtreecommitdiff
path: root/libre/parabolaweb-utils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/parabolaweb-utils/PKGBUILD')
-rw-r--r--libre/parabolaweb-utils/PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/libre/parabolaweb-utils/PKGBUILD b/libre/parabolaweb-utils/PKGBUILD
new file mode 100644
index 000000000..3b57c5d13
--- /dev/null
+++ b/libre/parabolaweb-utils/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
+
+. helper.sh
+# provides:
+# _get_pkgver
+# _get_depends
+# _get_depends_nover (no version requirements)
+
+pkgname=parabolaweb-utils
+pkgver=`_get_pkgver`
+pkgrel=1
+pkgdesc="Utils for the Parabola website"
+arch=('any')
+url="https://projects.parabolagnulinux.org/parabolaweb.git/"
+license=('GPL2')
+depends=('python2' 'git' 'libretools' `_get_depends`)
+
+export pkgver
+
+source=(git://parabolagnulinux.org/parabolaweb.git
+ parabolaweb.init.sh
+ update-parabolaweb)
+
+build() {
+ :
+}
+
+package() {
+ cd "${srcdir}"
+ install -d "${pkgdir}/${_install_dir}"
+ install -Dm755 parabolaweb.init.sh "${pkgdir}/etc/rc.d/parabolaweb"
+ install -Dm755 update-parabolaweb "${pkgdir}/usrls/sbin/update-parabolaweb"
+}
+
+md5sums=('SKIP'
+ 'f52aebbedaa61f688fb2bc626a783003'
+ 'dd05d6a4ea7cff7fdd789f59aeb9059a')