summaryrefslogtreecommitdiff
path: root/libre/pacman/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/pacman/PKGBUILD')
-rw-r--r--libre/pacman/PKGBUILD50
1 files changed, 25 insertions, 25 deletions
diff --git a/libre/pacman/PKGBUILD b/libre/pacman/PKGBUILD
index dc261b9aa..0eb78de7d 100644
--- a/libre/pacman/PKGBUILD
+++ b/libre/pacman/PKGBUILD
@@ -7,8 +7,8 @@
# Contributor: Daniel Milewski <niitotantei@riseup.net>
pkgname=pacman
-pkgver=5.2.2
-pkgrel=3
+pkgver=6.0.0
+pkgrel=2
pkgrel+=.parabola1
pkgdesc="A library-based package manager with dependency support"
arch=('x86_64')
@@ -19,7 +19,7 @@ groups=('base-devel')
depends=('bash' 'glibc' 'libarchive' 'curl'
'gpgme' 'pacman-mirrorlist' 'archlinux-keyring')
depends+=('parabola-keyring' 'archlinuxarm-keyring' 'archlinux32-keyring')
-makedepends=('asciidoc')
+makedepends=('meson' 'asciidoc' 'doxygen')
checkdepends=('python' 'fakechroot')
optdepends=('perl-locale-gettext: translation support in makepkg-template')
provides=('libalpm.so')
@@ -31,23 +31,21 @@ backup=(etc/pacman.conf
options=('strip' 'debug')
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
-source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
+source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.xz{,.sig}
"${arch[@]/#/pacman.conf.}"
makepkg.conf.in
- pacman-5.2.2-fix-strip-messing-up-file-attributes.patch::'https://git.archlinux.org/pacman.git/patch/?id=88d054093c1c99a697d95b26bd9aad5bc4d8e170'
pacman-keyring.service
pacman-keyring.timer
0004-makepkg-Treat-pkgrel-more-similarly-to-pkgver.patch)
source_armv7h=(0001-Sychronize-filesystem.patch
0002-Revert-close-stdin-before-running-install-scripts.patch
0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch)
-sha256sums=('bb201a9f2fb53c28d011f661d50028efce6eef2c1d2a36728bdd0130189349a0'
+sha256sums=('004448085a7747bdc7a0a4dd5d1fb7556c6b890111a06e029ab088f9905d4808'
'SKIP'
- 'fdc78b55947d41d08d9a0404b4fbb37e409517733ab11cbe336f5aaa24dcfffd'
- 'e5632e1581a4283cf8b93f0d32618fc7a35480c9caaf2d256c95f77645ae4265'
- 'd9bed26a58377b726ebadabd9729008e484f8719632b9c3e76c9320c2fcaa22c'
- 'ee4121a3a94fa0a0709be215e450b3c5b604bc03ffc32be8969d7461526dcc6b'
- '871fd97b3f13f1718358e4b8e046a56c0262c9042b5e3b5d60835606735798bd'
+ '29815f65c9dc402cd22651ae1b24def9a6b1525554b348b28a398530a79a1092'
+ '4a4198d6269a8a6b76edf66df4185c599f0b12e143fb7cc9a3497cc78f5e33f8'
+ 'a7bc662bda8e5707eddc2b8891fd756afed4aeea76e5a0145ecba128a8210d7f'
+ '39330da7fceba67e1ed5c8981e5565668711dbe46f4b305b84ac853da4bdd317'
'220f1b25a64727041dc6fa3fd486b0a043f735a3f6cecedc4e2f7c47ec6ce66d'
'2a857061f032ff5485f5c75ab74e6f6532621e08963ef48640a792cca16cacd6'
'9ccc7ef5bd27a68d8788f10c6e5b36495c5d9038d4eb160f9ea4dc9901b622d8')
@@ -57,7 +55,6 @@ sha256sums_armv7h=('8d70fb5094f58aad98b601bbc42be354c2014b9fe734a1ee0b1e14bb041c
prepare() {
cd "$pkgname-$pkgver"
- patch -Np1 < ../pacman-5.2.2-fix-strip-messing-up-file-attributes.patch
# From Arch ARM
if [ "${CARCH}" = "armv7h" ]; then
@@ -73,11 +70,15 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
- ./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --enable-doc \
- --with-scriptlet-shell=/usr/bin/bash \
- --with-ldconfig=/usr/bin/ldconfig
- make V=1
+ meson --prefix=/usr \
+ --buildtype=plain \
+ -Ddoc=enabled \
+ -Ddoxygen=enabled \
+ -Dscriptlet-shell=/usr/bin/bash \
+ -Dldconfig=/usr/bin/ldconfig \
+ build
+
+ meson compile -C build
# Generate the architecture-specific makepkg.conf files
local carch mycarch mychost myflags myldflags
@@ -87,24 +88,21 @@ build() {
mycarch="i686"
mychost="i686-pc-linux-gnu"
myflags="-march=i686 -mtune=generic -O2 -pipe -fno-plt -fexceptions \
- -Wp,-D_FORTIFY_SOURCE=2,-D_GLIBCXX_ASSERTIONS \
- -Wformat -Werror=format-security \
+ -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security \
-fstack-clash-protection -fcf-protection"
;;
x86_64)
mycarch="x86_64"
mychost="x86_64-pc-linux-gnu"
myflags="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions \
- -Wp,-D_FORTIFY_SOURCE=2,-D_GLIBCXX_ASSERTIONS \
- -Wformat -Werror=format-security \
+ -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security \
-fstack-clash-protection -fcf-protection"
;;
armv7h)
mycarch="armv7h"
mychost="armv7l-unknown-linux-gnueabihf"
myflags="-march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16 -O2 -pipe -fno-plt -fexceptions \
- -Wp,-D_FORTIFY_SOURCE=2,-D_GLIBCXX_ASSERTIONS \
- -Wformat -Werror=format-security \
+ -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security \
-fstack-clash-protection"
;;
esac
@@ -120,13 +118,15 @@ build() {
}
check() {
- make -C "$pkgname-$pkgver" check
+ cd "$pkgname-$pkgver"
+
+ meson test -C build
}
package() {
cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install -C build
# install distro-specific stuff
install -dm755 "$pkgdir"/etc/{makepkg,pacman}.d