summaryrefslogtreecommitdiff
path: root/libre/pacman/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/pacman/PKGBUILD')
-rw-r--r--libre/pacman/PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/libre/pacman/PKGBUILD b/libre/pacman/PKGBUILD
index 8fb58771b..f446e6e72 100644
--- a/libre/pacman/PKGBUILD
+++ b/libre/pacman/PKGBUILD
@@ -24,13 +24,10 @@ source=(ftp://ftp.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
pacman.conf.i686
pacman.conf.x86_64
pacman.conf.mips64el
- makepkg.conf)
-md5sums=('063c8b0ff6bdf903dc235445525627cd'
- 'SKIP'
- '688feb0a552f42643a76f72e7198bfe4'
- '77c5fd379e73cf86fc08a4bd5c4b1ba1'
- '9e0c64937ef751ae4273fa4d73381484'
- 'f0f310df411f943dbc4e2dd376c88662')
+ makepkg.conf
+ gpg.conf
+ sks-keyservers.netCA.pem
+ refresh-pacman-keys)
build() {
cd "$pkgname-$pkgver"
@@ -96,4 +93,13 @@ package() {
done
install -Dm644 contrib/PKGBUILD.vim "$pkgdir/usr/share/vim/vimfiles/syntax/PKGBUILD.vim"
+
+ install -Dm755 "${srcdir}/refresh-pacman-keys" \
+ "${pkgdir}/etc/cron.weekly/refresh-pacman-keys"
+
+ install -Dm644 "${srcdir}/sks-keyservers.netCA.pem" \
+ "${pkgdir}/etc/pacman.d/sks-keyservers.netCA.pem"
+
+ install -Dm644 "${srcdir}/gpg.conf" \
+ "${pkgdir}/etc/pacman.d/gpg.conf"
}