summaryrefslogtreecommitdiff
path: root/libre/pacman-parabola/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/pacman-parabola/PKGBUILD')
-rw-r--r--libre/pacman-parabola/PKGBUILD115
1 files changed, 115 insertions, 0 deletions
diff --git a/libre/pacman-parabola/PKGBUILD b/libre/pacman-parabola/PKGBUILD
new file mode 100644
index 000000000..de3551045
--- /dev/null
+++ b/libre/pacman-parabola/PKGBUILD
@@ -0,0 +1,115 @@
+# vim: set ts=2 sw=2 et:
+# $Id: PKGBUILD 211992 2014-05-04 02:54:25Z allan $
+# Maintainer (Arch): Dan McGee <dan@archlinux.org>
+# Maintainer (Arch): Dave Reisner <dreisner@archlinux.org>
+
+_pkgname=pacman
+pkgname=pacman-parabola
+pkgver=4.1.2
+pkgrel=6
+pkgdesc="A library-based package manager with dependency support"
+arch=('i686' 'x86_64' 'mips64el')
+url="http://www.archlinux.org/pacman/"
+license=('GPL')
+groups=('base' 'base-devel')
+depends=('bash>=4.2.042-2' 'glibc>=2.17-2' 'libarchive>=3.1.2' 'curl>=7.19.4'
+ 'gpgme' 'pacman-mirrorlist' 'archlinux-keyring' 'parabola-keyring' 'cacert-dot-org')
+checkdepends=('python2' 'fakechroot')
+optdepends=('fakeroot: for makepkg usage as normal user')
+provides=('pacman-contrib' "$_pkgname")
+conflicts=('pacman-contrib' "$_pkgname")
+replaces=('pacman-contrib' "$_pkgname=$pkgver")
+backup=(etc/pacman.conf etc/makepkg.conf)
+options=('strip' 'debug')
+source=(ftp://ftp.archlinux.org/other/pacman/$_pkgname-$pkgver.tar.gz{,.sig}
+ pacman.conf.i686
+ pacman.conf.x86_64
+ pacman.conf.mips64el
+ makepkg.conf
+ gpg.conf
+ sks-keyservers.netCA.pem
+ refresh-pacman-keys)
+md5sums=('063c8b0ff6bdf903dc235445525627cd'
+ 'SKIP'
+ '688feb0a552f42643a76f72e7198bfe4'
+ '77c5fd379e73cf86fc08a4bd5c4b1ba1'
+ '9e0c64937ef751ae4273fa4d73381484'
+ 'f0f310df411f943dbc4e2dd376c88662'
+ '8c339b2bf027979d1edcfc6ac0e7e81d'
+ '3cfc5d2867a6672f4f629220632948f4'
+ '093f0779ac55ae781ba028ad74b95f84')
+
+build() {
+ cd "$_pkgname-$pkgver"
+
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --enable-doc \
+ --with-scriptlet-shell=/usr/bin/bash \
+ --with-ldconfig=/usr/bin/ldconfig
+ make
+ make -C contrib
+}
+
+check() {
+ make -C "$_pkgname-$pkgver" check
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" -C contrib install
+
+ # install Arch specific stuff
+ install -dm755 "$pkgdir/etc"
+ install -m644 "$srcdir/pacman.conf.$CARCH" "$pkgdir/etc/pacman.conf"
+
+ case $CARCH in
+ i686)
+ mycarch="i686"
+ mychost="i686-pc-linux-gnu"
+ myflags="-march=i686 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4"
+ myldflags="-Wl,-O1,--sort-common,--as-needed,-z,relro,--hash-style=gnu"
+ ;;
+ x86_64)
+ mycarch="x86_64"
+ mychost="x86_64-unknown-linux-gnu"
+ myflags="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4"
+ myldflags="-Wl,-O1,--sort-common,--as-needed,-z,relro,--hash-style=gnu"
+ ;;
+ mips64el)
+ mycarch="mips64el"
+ mychost="mips64el-unknown-linux-gnu"
+ myflags="-O2 -march=mips3 -mtune=loongson2f -mabi=n32 -pipe -mplt -Wa,-mfix-loongson2f-nop -fstack-protector-strong --param=ssp-buffer-size=4"
+ myldflags="-Wl,-O1,--sort-common,--as-needed,-z,relro"
+ ;;
+ esac
+
+ # set things correctly in the default conf file
+ install -m644 "$srcdir/makepkg.conf" "$pkgdir/etc"
+ sed -i "$pkgdir/etc/makepkg.conf" \
+ -e "s|@CARCH[@]|$mycarch|g" \
+ -e "s|@CHOST[@]|$mychost|g" \
+ -e "s|@LDFLAGS[@]|$myldflags|g" \
+ -e "s|@CARCHFLAGS[@]|$myflags|g"
+
+ # put bash_completion in the right location
+ install -dm755 "$pkgdir/usr/share/bash-completion/completions"
+ mv "$pkgdir/etc/bash_completion.d/pacman" "$pkgdir/usr/share/bash-completion/completions"
+ rmdir "$pkgdir/etc/bash_completion.d"
+
+ for f in makepkg pacman-key; do
+ ln -s pacman "$pkgdir/usr/share/bash-completion/completions/$f"
+ done
+
+ install -Dm644 contrib/PKGBUILD.vim "$pkgdir/usr/share/vim/vimfiles/syntax/PKGBUILD.vim"
+
+ install -Dm755 "${srcdir}/refresh-pacman-keys" \
+ "${pkgdir}/etc/cron.weekly/refresh-pacman-keys"
+
+ install -Dm644 "${srcdir}/sks-keyservers.netCA.pem" \
+ "${pkgdir}/etc/pacman.d/sks-keyservers.netCA.pem"
+
+ install -Dm644 "${srcdir}/gpg.conf" \
+ "${pkgdir}/etc/pacman.d/gpg.conf"
+}