summaryrefslogtreecommitdiff
path: root/libre/p7zip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/p7zip/PKGBUILD')
-rw-r--r--libre/p7zip/PKGBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/libre/p7zip/PKGBUILD b/libre/p7zip/PKGBUILD
index 904b7d909..68d0ce310 100644
--- a/libre/p7zip/PKGBUILD
+++ b/libre/p7zip/PKGBUILD
@@ -1,15 +1,16 @@
-# $Id: PKGBUILD 252408 2015-12-05 15:21:01Z bpiotrowski $
+# $Id: PKGBUILD 267789 2016-05-11 10:17:43Z foutrelis $
+# Maintainer (Arch): Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor (Arch): Gaetan Bisson <bisson@archlinux.org>
# Contributor (Arch): Thayer Williams <thayer@archlinux.org>
# Contributor (Arch): Hugo Doria <hugo@archlinux.org>
# Contributor (Arch): TuxSpirit<tuxspirit@archlinux.fr> 2007/11/17 21:22:36 UTC
# Contributor (Arch): Daniel J Griffiths <ghost1227@archlinux.us>
-# Maintainer (Arch): Gaetan Bisson <bisson@archlinux.org>
# Maintainer: André Silva <emulatorman@parabola.nu>
_pkgname=p7zip-libre
pkgname=p7zip
-pkgver=9.38.1
-pkgrel=4.parabola1
+pkgver=15.14.1
+pkgrel=1.parabola1
pkgdesc="Command-line file archiver with high compression ratio"
arch=('i686' 'x86_64' 'armv7h')
url="http://p7zip.sourceforge.net/"
@@ -20,12 +21,12 @@ depends=('gcc-libs' 'sh')
makedepends_i686=('nasm')
makedepends_x86_64=('yasm')
install=$pkgname.install
-mksource=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}_${pkgver}_src_all.tar.bz2")
-source=("https://repo.parabola.nu/other/${_pkgname}/${_pkgname}_${pkgver}_src_all.tar.bz2"
- 'libre.patch')
-mksha256sums=('fd5019109c9a1bf34ad3257d37a6853eae8151ff50345f0a3ffba7d8c5fdb995')
-sha256sums=('ef4011f2d2387d8e11d504aaf603b1a4d92984c281784fe7663b74ba952f8d7e'
- '1a1f779471532d30a8722f563f3189932f955b57bb1a94a32b7aa3a31dcd34ed')
+mksource=(https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/${pkgname}_${pkgver}_src_all.tar.bz2)
+source=(https://repo.parabola.nu/other/${_pkgname}/${_pkgname}_${pkgver}_src_all.tar.bz2
+ libre.patch)
+mksha256sums=('699db4da3621904113e040703220abb1148dfef477b55305e2f14a4f1f8f25d4')
+sha256sums=('2b43c19d4367356d38f78b020f58f874a5222022c7bc8e3f9620ab3c1899f61b'
+ 'dd64ba789b8c23ecd3fbcccbcd62a217035de3a8c98517e7ba140a1a546ae77a')
mksource() {
cd "${srcdir}/${pkgname}_${pkgver}"
@@ -33,8 +34,8 @@ mksource() {
# Remove nonfree unRAR utility files from the source
rm -rv CPP/7zip/{Archive,Compress}/Rar
rm -v CPP/7zip/Compress/{Rar{1,2,3}Decoder.{cpp,h},Rar3Vm.{cpp,h},RarCodecsRegister.cpp}
- rm -v CPP/7zip/Crypto/{Rar20Crypto,RarAes}.{cpp,h}
- rm -v Utils/file_Codecs_Rar29_so.py
+ rm -v CPP/7zip/Crypto/{Rar20Crypto,Rar{,5}Aes}.{cpp,h}
+ rm -v Utils/file_Codecs_Rar_so.py
rm -v DOC/unRarLicense.txt
# Remove nonfree parent folder icon