summaryrefslogtreecommitdiff
path: root/libre/openexr/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/openexr/PKGBUILD')
-rw-r--r--libre/openexr/PKGBUILD41
1 files changed, 16 insertions, 25 deletions
diff --git a/libre/openexr/PKGBUILD b/libre/openexr/PKGBUILD
index ac5bf7377..9fecd883c 100644
--- a/libre/openexr/PKGBUILD
+++ b/libre/openexr/PKGBUILD
@@ -3,10 +3,14 @@
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
# Contributor: grizzlyuser <grizzlyuser@protonmail.com>
+# parabola changes and rationale
+# * removed documentation with embedded non-free fonts
+
+
pkgname=openexr
-pkgver=2.4.1
-pkgrel=2
-pkgrel+=.parabola2
+pkgver=2.5.1
+pkgrel=1
+pkgrel+=.parabola1
pkgdesc="An high dynamic-range image file format library"
pkgdesc+=", without embedded nonfree fonts in the documentation"
url="https://www.openexr.com/"
@@ -15,34 +19,22 @@ arch+=('i686' 'armv7h')
license=('BSD3')
depends=('zlib')
makedepends=('cmake' 'fltk' 'python' 'boost' 'freeglut' 'python-numpy' 'chrpath')
-makedepends+=('unoconv' 'libepoxy' 'ttf-croscore' 'ttf-caladea' 'ttf-carlito' 'gsfonts' 'ttf-bitstream-vera')
optdepends=('fltk: for exrdisplay' 'boost-libs: python support' 'python: python support')
+optdepends+=('libreoffice-still: for reading documentation')
conflicts=('ilmbase')
replaces=('ilmbase')
-source=($pkgname-$pkgver.tar.gz::"https://github.com/AcademySoftwareFoundation/openexr/archive/v$pkgver.tar.gz"
- openexr-pc-prefix.patch::"https://github.com/AcademySoftwareFoundation/openexr/commit/0b26a9de.patch")
-sha256sums=('3ebbe9a8e67edb4a25890b98c598e9fe23b10f96d1416d6a3ff0732e99d001c1'
- 'f20d7588badb679828816e0ada201705b7d1cc5a4d82df3d586707a792b10950')
+options=(!debug)
+source=($pkgname-$pkgver.tar.gz::"https://github.com/openexr/openexr/archive/v$pkgver.tar.gz"
+ install-odt-docs-not-pdf.patch)
+sha256sums=('11f806bf256453e39fc33bd1cf1fa576a54f144cedcdd3e6935a177e5a89d02e'
+ 'fd0cc640265605b6a25db3dd901641be3adebfa2b748e6b559cffcba1e5ceb94')
prepare() {
cd $pkgname-$pkgver
- patch -p1 -i ../openexr-pc-prefix.patch # Fix prefix in pc file
-
- # remove documentation with embedded nonfree fonts
- rm -v OpenEXR/doc/{InterpretingDeepPixels,MultiViewOpenEXR,OpenEXRFileLayout,ReadingAndWritingImageFiles,TechnicalIntroduction,TheoryDeepPixels}.pdf
- rm -v OpenEXR_Viewers/doc/OpenEXRViewers.pdf
-
- # convert source documentation to pdf format and clean source code
- pushd OpenEXR/doc
- unoconv -v -f pdf {InterpretingDeepPixels.docx,{MultiViewOpenEXR,OpenEXRFileLayout,ReadingAndWritingImageFiles,TechnicalIntroduction}.odt}
- popd
- pushd OpenEXR_Viewers/doc
- unoconv -v -f pdf OpenEXRViewers.odt
- popd
- # remove TheoryDeepPixels.pdf reference
- sed -i '\|TheoryDeepPixels[.]pdf|d
- ' "OpenEXR/doc/CMakeLists.txt"
+ # remove documentation with embedded non-free fonts
+ find . -name *.pdf -exec rm -v '{}' \;
+ patch -p1 < "$srcdir"/install-odt-docs-not-pdf.patch
}
build() {
@@ -58,7 +50,6 @@ package() {
cd build
make DESTDIR="${pkgdir}" install
install -D -m644 "$srcdir"/$pkgname-$pkgver/LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 "$srcdir/$pkgname-$pkgver/OpenEXR/doc/"{InterpretingDeepPixels.docx,{MultiViewOpenEXR,OpenEXRFileLayout,ReadingAndWritingImageFiles,TechnicalIntroduction}.odt} "${pkgdir}/usr/share/doc/OpenEXR"
# Install missing python module
_pythonpath=`python -c "from sysconfig import get_path; print(get_path('platlib'))"`