summaryrefslogtreecommitdiff
path: root/libre/nextcloud-client/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/nextcloud-client/PKGBUILD')
-rw-r--r--libre/nextcloud-client/PKGBUILD63
1 files changed, 30 insertions, 33 deletions
diff --git a/libre/nextcloud-client/PKGBUILD b/libre/nextcloud-client/PKGBUILD
index 69a997b48..2fe462798 100644
--- a/libre/nextcloud-client/PKGBUILD
+++ b/libre/nextcloud-client/PKGBUILD
@@ -8,9 +8,9 @@
pkgname=nextcloud-client
-pkgver=2.6.1
-_commit=5adbc01ef138efd252c5c8c340f57dae0b34d8b9
-pkgrel=2
+pkgver=2.6.2
+_commit=1d745535f7a95ff2265d6b6b47121200338fce83
+pkgrel=1
pkgrel+=.parabola1
pkgdesc='Nextcloud desktop client'
pkgdesc+=', without nonfree qt5-webengine dependency'
@@ -18,41 +18,41 @@ arch=(x86_64)
arch+=(i686 armv7h)
url='https://nextcloud.com/'
license=(GPL)
-
-depends=('openssl' 'sqlite' 'qtkeychain' 'qt5-svg' 'xdg-utils')
+depends=(openssl sqlite qtkeychain qt5-svg xdg-utils libcloudproviders)
+makedepends=(doxygen extra-cmake-modules kio python-sphinx qt5-tools git cmocka)
optdepends=(
'kio: integration with Dolphin'
'nemo-python: integration with Nemo'
'python-nautilus: integration with Nautilus'
'python2-caja: integration with Caja'
)
-makedepends=('doxygen' 'extra-cmake-modules' 'kio' 'python-sphinx' 'qt5-tools' 'git' 'cmocka')
-backup=(etc/Nextcloud/sync-exclude.lst)
-
-source=($pkgname::git+https://github.com/nextcloud/desktop.git?signed#commit=$_commit
+source=("$pkgname::git+https://github.com/nextcloud/desktop.git?signed#commit=$_commit"
issue1458-workaround.patch::https://github.com/yan12125/desktop/commit/7da680ef7843a52c3136916744f50d4a003bb8b5.patch
issue1458-2.patch::https://github.com/yan12125/desktop/commit/2b313368325dac5b8d0e69394cfcc4faaa745f75.patch
- remove-qtwebengine.patch
- $pkgname-fix-build.diff)
-validpgpkeys=('A26B951528EA1BA1678C7AE5D406C75CEE1A36D6') # one of keys controlled by github.com/camilasan
+ $pkgname-fix-build.diff
+ $pkgname-FS64630.diff)
+source+=(remove-qtwebengine.patch)
+validpgpkeys=(
+ A26B951528EA1BA1678C7AE5D406C75CEE1A36D6 # one of keys controlled by github.com/camilasan
+ 42E775EAA3E47F9E0D5CDB0E00819E3BF4177B28 # controlled by github.com/misch7
+)
sha256sums=('SKIP'
'07cd68f54c004175b4a09cce25830a357d0ebaafaf4e4cabfb8b0d4deeded2f3'
'157c87a789219a3442ca5947c48dcd1ef3898612ff32070bf8842a42bfbe857a'
- '0e036c1f9f200aff057092f5a5848a5f496903bac51105349b87b2cf11b04958'
- '8b257a0554ceb54a7ed320dbfa3becb97d6845338e28a8aa0a4f6239f3141645')
-
-
-prepare()
-{
- cd "$srcdir/$pkgname/"
+ '8b257a0554ceb54a7ed320dbfa3becb97d6845338e28a8aa0a4f6239f3141645'
+ '6dea4453f220b63b993722cb155d567959600af261403870f5e34d35144a4fa7')
+sha256sums+=('77d7afd2dc65a7625e1617dd2c287c1be004deca2f64ecc18a96bb6c3cd733cf')
+backup=('etc/Nextcloud/sync-exclude.lst')
+prepare() {
# tmpdir for check()
- mkdir tmpdir "$srcdir/$pkgname/build"
+ mkdir tmpdir $pkgname/build
# Use system GNUInstallDirs.cmake so that we can benefit from
# https://gitlab.kitware.com/cmake/cmake/merge_requests/3735
- rm -v cmake/modules/GNUInstallDirs.cmake
+ rm -v $pkgname/cmake/modules/GNUInstallDirs.cmake
+ cd $pkgname
patch -Np1 -i ../issue1458-workaround.patch
patch -Np1 -i ../issue1458-2.patch
@@ -60,13 +60,15 @@ prepare()
# "Rename owncloud tests to nextcloud" - actually breaks building of tests
patch -Np1 -i ../$pkgname-fix-build.diff
+ # https://bugs.archlinux.org/task/64630
+ patch -Np1 -i ../$pkgname-FS64630.diff
+
# Remove qt5-webengine dependency
patch -Np1 -i ../remove-qtwebengine.patch
}
-build()
-{
- cd "$srcdir/$pkgname/build"
+build() {
+ cd $pkgname/build
# bundled breakpad in libcrashreporter-qt submodule is too old and does not build with glibc >= 2.26
# Upstream fix: https://github.com/google/breakpad/commit/bddcc58860f522a0d4cbaa7e9d04058caee0db9d
@@ -83,21 +85,16 @@ build()
make doc-man
}
-check()
-{
- cd "$srcdir/$pkgname/build"
-
- # many tests fail on i686 and armv7h
- [ "$CARCH" == 'i686' ] || [ "$CARCH" == 'armv7h' ] && return 0
+check() {
+ cd $pkgname/build
# Tests fail if $TMPDIR is too small; specify an alternative for machines
# with a small /tmp partition.
TMPDIR="$srcdir/tmpdir" make test ARGS="-V"
}
-package()
-{
- cd "$srcdir/$pkgname/build"
+package() {
+ cd $pkgname/build
make DESTDIR="$pkgdir" install
}