summaryrefslogtreecommitdiff
path: root/libre/mc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/mc/PKGBUILD')
-rw-r--r--libre/mc/PKGBUILD32
1 files changed, 20 insertions, 12 deletions
diff --git a/libre/mc/PKGBUILD b/libre/mc/PKGBUILD
index 612bc58b6..856aca45f 100644
--- a/libre/mc/PKGBUILD
+++ b/libre/mc/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 215416 2017-03-09 17:51:32Z schuay $
+# Maintainer (Arch): Alad Wenter <alad@archlinux.org>
# Maintainer (Arch): schuay <jakob.gruber@gmail.com>
# Contributor (Arch): Daniel J Griffiths <ghost1227@archlinux.us>
# Maintainer (Hyperbola): André Silva <emulatorman@hyperbola.info>
@@ -6,11 +6,14 @@
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname=mc
-pkgver=4.8.20
-pkgrel=1.parabola1
-pkgdesc="Midnight Commander is a text based filemanager/shell that emulates Norton Commander, with arj recommendation included and nonfree unace and unrar support removed"
-arch=('i686' 'x86_64' 'armv7h')
-url="http://www.ibiblio.org/mc/"
+pkgver=4.8.24
+pkgrel=2
+pkgrel+=.parabola1
+pkgdesc="A file manager that emulates Norton Commander"
+pkgdesc+=", with arj recommendation included and nonfree unace and unrar support removed"
+arch=('x86_64')
+arch+=('i686' 'armv7h')
+url="https://midnight-commander.org/"
license=('GPL')
depends=('e2fsprogs' 'glib2' 'gpm' 'libssh2' 'slang')
makedepends=('libxt' 'libx11' 'unzip')
@@ -23,8 +26,8 @@ optdepends=('aspell: spelling corrections'
'mtools: a+ extfs'
'p7zip: support for 7zip archives'
'perl: needed by several extfs scripts'
- 'python2-boto: s3+ extfs'
- 'python2-pytz: s3+ extfs'
+ 'python-boto: s3+ extfs'
+ 'python-pytz: s3+ extfs'
'samba: VFS support'
'arj: uarj extfs'
'zip: uzip extfs')
@@ -39,25 +42,30 @@ backup=('etc/mc/edit.indent.rc'
'etc/mc/sfs.ini')
options=('!emptydirs')
source=("http://ftp.midnight-commander.org/${pkgname}-${pkgver}.tar.xz"
+ "mc-mksh-subshell-v2.patch"
+ "mc-python3.patch"
'libre.patch')
-sha256sums=('017ee7f4f8ae420a04f4d6fcebaabe5b494661075c75442c76e9c8b1923d501c'
- '09a44d10ed1081ada579dd42fb67cdea8755f4a3aa496433df9a726b90f11862')
+sha256sums=('859f1cc070450bf6eb4d319ffcb6a5ac29deb0ac0d81559fb2e71242b1176d46'
+ '5147afa3f9dfc00d8b7b36bbb144bcdb78d86301a0f8196686262a9eee41fb96'
+ '10ab8b8c03770f8fe51f0bdbf0d66a44313bf2eed687cf769397909c07d8e8d5'
+ '0129171a9af3d1a7e37be232809e3f42921ef8fa016974234ca61f3fa180232b')
prepare() {
cd ${pkgname}-${pkgver}
+ patch -p1 < "$srcdir"/mc-mksh-subshell-v2.patch
+ patch -p1 < "$srcdir"/mc-python3.patch
patch -Np1 -i ../libre.patch
rm -v src/vfs/extfs/helpers/u{ace,rar}.in
}
build() {
- export PYTHON=/usr/bin/python2
-
cd ${pkgname}-${pkgver}
./configure \
--prefix=/usr \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
--enable-vfs-smb \
+ --with-screen=slang \
--with-x
make
}