summaryrefslogtreecommitdiff
path: root/libre/mc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/mc/PKGBUILD')
-rw-r--r--libre/mc/PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/libre/mc/PKGBUILD b/libre/mc/PKGBUILD
index 0ab63d0ac..d30c644c3 100644
--- a/libre/mc/PKGBUILD
+++ b/libre/mc/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 174449 2016-05-09 17:51:10Z schuay $
+# $Id: PKGBUILD 190233 2016-09-24 07:17:41Z schuay $
# Maintainer (Arch): schuay <jakob.gruber@gmail.com>
# Contributor (Arch): Daniel J Griffiths <ghost1227@archlinux.us>
# Maintainer: André Silva <emulatorman@parabola.nu>
@@ -6,7 +6,7 @@
pkgname=mc
pkgver=4.8.17
-pkgrel=1.parabola1
+pkgrel=2.parabola1
pkgdesc="Midnight Commander is a text based filemanager/shell that emulates Norton Commander, with arj recommendation included and nonfree unace and unrar support removed"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.ibiblio.org/mc/"
@@ -38,18 +38,23 @@ backup=('etc/mc/edit.indent.rc'
'etc/mc/sfs.ini')
options=('!emptydirs')
source=("http://ftp.midnight-commander.org/${pkgname}-${pkgver}.tar.xz"
+ "0001-Ticket-3639-fix-window-resizing-when-panels-are-hidd.patch"
+ "0002-Do-not-botch-SIGWINCH-delivery-to-the-subshell.patch"
'libre.patch')
sha256sums=('0447bdddc0baa81866e66f50f9a545d29d6eebb68b0ab46c98d8fddd2bf4e44d'
+ '9a3639ff068dfddee0342d631b56d8df6c0240105802fb00edb0fa3a265e95d6'
+ '2a5ab735226ce41b0ebbb4bcedb0e04e82ea3cb14e2776acede1e58816f3d787'
'a72558445fd1558e18d0fb0be767f4460d04130e80cd87ad84b376fab1b66357')
prepare() {
cd ${pkgname}-${pkgver}
+ patch -Np1 < ${srcdir}/0001-Ticket-3639-fix-window-resizing-when-panels-are-hidd.patch
+ patch -Np1 < ${srcdir}/0002-Do-not-botch-SIGWINCH-delivery-to-the-subshell.patch
patch -Np1 -i ../libre.patch
rm -v src/vfs/extfs/helpers/u{ace,rar}.in
}
-
build() {
export PYTHON=/usr/bin/python2