summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rwxr-xr-xlibre/linux-libre/PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 452929cce..26c18da17 100755
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -12,8 +12,8 @@ pkgbase=linux-libre # Build stock -LIBRE kernel
_basekernel=3.7
_sublevel=1
pkgver=${_basekernel}.${_sublevel}
-pkgrel=1
-_lxopkgver=${_basekernel}.0 # nearly always the same as pkgver
+pkgrel=2
+_lxopkgver=${_basekernel}.1 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -30,6 +30,7 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'boot-logo.patch'
'change-default-console-loglevel.patch'
'fat-3.6.x.patch'
+ 'fix-watchdog-3.7.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
md5sums=('06bf9601d859531e7378eb43d4ca7dd3'
'6f4bb80d3d91b69daf5ccfea836d02df'
@@ -41,7 +42,8 @@ md5sums=('06bf9601d859531e7378eb43d4ca7dd3'
'04b21c79df0a952c22d681dd4f4562df'
'9d3c56a4b999c8bfbd4018089a62f662'
'88d501404f172dac6fcb248978251560'
- '0a74f8d9c640daabb774c25cb74db512')
+ '3485d6c7ae3af35d16e09d6d9a7ed32a'
+ 'b56c33eaee920970151fffdfc7df0766')
if [ "$CARCH" != "mips64el" ]; then
# Don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -70,6 +72,10 @@ build() {
# https://bugs.archlinux.org/task/32916
patch -Np1 -i "${srcdir}/fat-3.6.x.patch"
+ # fix watchdog enable/disable regression
+ # https://bugs.archlinux.org/task/33095
+ patch -Np1 -i "${srcdir}/fix-watchdog-3.7.patch"
+
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre|" Makefile
sed -r "s|^( SUBLEVEL = ).*|\1$_sublevel|" \