summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 1de83d8b9..d7479db9e 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 216981 2014-07-18 05:18:53Z tpowa $
+# $Id: PKGBUILD 219731 2014-08-14 06:02:01Z tpowa $
# Maintainer (Arch): Tobias Powalowski <tpowa@archlinux.org>
# Maintainer (Arch): Thomas Baechler <thomas@archlinux.org>
# Maintainer: André Silva <emulatorman@parabola.nu>
@@ -10,11 +10,11 @@
pkgbase=linux-libre # Build stock -libre kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
-_basekernel=3.15
-_sublevel=6
+_basekernel=3.16
+_sublevel=1
pkgver=${_basekernel}.${_sublevel}
pkgrel=1
-_lxopkgver=${_basekernel}.5 # nearly always the same as pkgver
+_lxopkgver=${_basekernel}.0 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -30,19 +30,19 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'Kbuild.platforms'
'boot-logo.patch'
'change-default-console-loglevel.patch'
- '0013-efistub-fix.patch'
+ 'compal-laptop-hwmon-fix.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.xz")
-sha256sums=('93450dc189131b6a4de862f35c5087a58cc7bae1c24caa535d2357cc3301b688'
- '1966964395bd9331843c8d6dacbf661c9061e90c81bf8609d995ed458d57e358'
- '5d56d5674977da86def67269fb7e0245e382af25ea52acbe17bc2a641a8b9b0e'
- '25b3afffe577540c8b7bf68f0a3aae5e9ac2c2b2841349a91b5048d742ba0d1f'
+sha256sums=('9c2a524c901febe0f0138f702bfdeb52d6f79f22c1fdbabaa37580bc70f16218'
+ '3bbc78694d76b12b6229799d7c4daf5215b9dd731908d96b03603aceb54ad5c7'
+ '46f70101acc6ffa57ea8f077db55ad554dd4b335c2e0fa85edf61db9f89c45ed'
+ '5b809f025fc13ccffb77092fadf044b4a52d9b8242028b01d15845589c4e1e19'
'dfe01c93d83cdac9ca502715ceb6ac9502d327c939fec2e3052a5a58422dc176'
'c5451d5e1eafc4f8d28b1a2958ec3102c124433a414a86450fc32058e004156b'
'55bf07738a3286168a7929ae16dbca29defd14e77b9d24c487ae4c3d12bb9eb9'
'8303b426b1a6dce456b2350003558ae312d21cab0ae6c1f0d7b9d21395f4e177'
- 'faced4eb4c47c4eb1a9ee8a5bf8a7c4b49d6b4d78efbe426e410730e6267d182'
- '937dc895b4f5948381775a75bd198ed2f157a9f356da0ab5a5006f9f1dacde5c'
- 'ca0399ad601efd926a3d6e328d6457a7e945fe982e4f13ed39fff31982082f28')
+ '1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
+ 'f36f61a0a72bcb0a9c04264343503bfbf927c9ea0db819e66734a3933b060588'
+ '86a5e1ab424fe5dec8dffe24253d11575d5e7a51b7fb117db95a5bf1efdba3fd')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -70,9 +70,8 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
- # fix efistub hang #33745
- # https://git.kernel.org/cgit/linux/kernel/git/mfleming/efi.git/patch/?id=c7fb93ec51d462ec3540a729ba446663c26a0505
- patch -Np1 -i "${srcdir}/0013-efistub-fix.patch"
+ # #41458 fix hwmon for compal-laptop module
+ patch -p1 -i "${srcdir}/compal-laptop-hwmon-fix.patch"
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre|" Makefile