summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index ebf30af10..5b4d785d4 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 203524 2014-01-12 13:05:55Z tpowa $
+# $Id: PKGBUILD 204729 2014-01-26 08:54:46Z thomas $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
@@ -10,10 +10,10 @@
pkgbase=linux-libre # Build stock -LIBRE kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
_basekernel=3.12
-_sublevel=7
+_sublevel=9
pkgver=${_basekernel}.${_sublevel}
-pkgrel=2
-_lxopkgver=${_basekernel}.7 # nearly always the same as pkgver
+pkgrel=1
+_lxopkgver=${_basekernel}.9 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -38,7 +38,7 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-notification-fails.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
md5sums=('254f59707b6676b59ce5ca5c3c698319'
- 'c42ff446236915fe1a6e2b6f9724d267'
+ '348975e36e4dd27f5d8fc50e92de8922'
'568ce15a9df133072489cbac8c4fefb3'
'772873c548059c57c8ec7898f35c0e2b'
'e49ac236dfeef709f91a3d993ea7b62c'
@@ -53,7 +53,7 @@ md5sums=('254f59707b6676b59ce5ca5c3c698319'
'cec0bb8981936eab2943b2009b7a6fff'
'88d9cddf9e0050a76ec4674f264fb2a1'
'cb9016630212ef07b168892fbcfd4e5d'
- '7554da820df91c282656972976d9e0b5')
+ '9cdff00e5aa53962869857d64a1ccf01')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -76,6 +76,9 @@ prepare() {
# fix issue on Hal8188EFWImg_CE.c deblobbed file
sed -i "\|DEBLOBBED| s|,||" drivers/staging/rtl8188eu/hal/Hal8188EFWImg_CE.c
+ # add latest fixes from stable queue, if needed
+ # http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
+
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
@@ -85,7 +88,7 @@ prepare() {
# patch from fedora
patch -Np1 -i "${srcdir}/criu-no-expert.patch"
- # fix 15 seocnds nfs delay
+ # fix 15 seconds nfs delay
patch -Np1 -i "${srcdir}/sunrpc-create-a-new-dummy-pipe-for-gssd-to-hold-open.patch"
patch -Np1 -i "${srcdir}/sunrpc-replace-gssd_running-with-more-reliable-check.patch"
patch -Np1 -i "${srcdir}/nfs-check-gssd-running-before-krb5i-auth.patch"