summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 312f129e9..94b1c7a93 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -1,8 +1,10 @@
# $Id: PKGBUILD 130991 2011-07-09 12:23:51Z thomas $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
-# Maintainer (Parabola: Nicolás Reynolds <fauno@kiwwwi.com.ar>
-pkgbase="linux-libre"
+# Maintainer (Parabola): Nicolás Reynolds <fauno@kiwwwi.com.ar>
+# Contributor (Parabola): Sorin-Mihai Vârgolici <smv@yobicore.org>
+
+pkgbase=linux-libre
pkgname=('linux-libre' 'linux-libre-headers' 'linux-libre-docs') # Build stock -LIBRE kernel
# pkgname=linux-custom # Build kernel with a different name
_kernelname=${pkgname#linux-libre}
@@ -14,7 +16,7 @@ url="http://linux-libre.fsfla.org"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl')
options=('!strip')
-source=(http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-libre/linux-${pkgver}-libre.tar.xz
+source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-libre/linux-${pkgver}-libre.tar.xz"
# the main kernel config files
'config.i686' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -31,13 +33,13 @@ md5sums=('44e7bc20c235a193f9b6123a8d5e9509'
'7396b811db06dec0250a1a098f527b83')
build() {
- cd ${srcdir}/linux-$pkgver
+ cd "${srcdir}/linux-$pkgver"
# fix #19234 i1915 display size
- patch -Np1 -i ${srcdir}/fix-i915.patch
+ patch -Np1 -i "${srcdir}/fix-i915.patch"
# Add freedo as boot logo
- patch -Np1 -i ${srcdir}/boot-logo.patch
+ patch -Np1 -i "${srcdir}/boot-logo.patch"
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream