summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rwxr-xr-xlibre/linux-libre/PKGBUILD34
1 files changed, 10 insertions, 24 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 45888f407..a0f8777e6 100755
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -9,11 +9,11 @@
pkgbase=linux-libre # Build stock -LIBRE kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
-_basekernel=3.5
-_sublevel=4
+_basekernel=3.6
+_sublevel=2
pkgver=${_basekernel}.${_sublevel}
pkgrel=1
-_lxopkgver=${_basekernel}.4 # nearly always the same as pkgver
+_lxopkgver=${_basekernel}.1 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -29,23 +29,17 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'Kbuild.platforms'
'boot-logo.patch'
'change-default-console-loglevel.patch'
- 'alsa-powersave-3.5.x.patch'
- 'watchdog-3.5.x.patch'
- 'i915-i2c-crash-3.5.x.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
-md5sums=('2407fc9563a74acaf38aa0c06516eb1c'
- '51fd8205ef5bcebc8c777a30c57b1fa2'
- 'd83444b46ed5088e47f38cce2641023c'
- '1ca6f15729d07ae7b3969eea3b4d8cff'
+md5sums=('a2312edd0265b5b07bd4b50afae2b380'
+ '1014a197e2bea449600d7b2cca415eec'
+ '600af9b069c8a1c18dd5ef1f25bf7080'
+ 'c18004748092bf4ee57ade7e25fdef22'
'e49ac236dfeef709f91a3d993ea7b62c'
'2967cecc3af9f954ccc822fd63dca6ff'
'8267264d9a8966e57fdacd1fa1fc65c4'
'04b21c79df0a952c22d681dd4f4562df'
'9d3c56a4b999c8bfbd4018089a62f662'
- 'c1d58e712112cf8f95e7831012a1e67a'
- 'ae13ed1e92bba07e9b17cf5c8d89683c'
- 'ff4a203dd52e4dfb5d60948bb667d06d'
- 'd5c5a9bb87544c9fbc19c661802f9020')
+ '1690532ad271b11a87e8824f7da65101')
if [ "$CARCH" != "mips64el" ]; then
# Don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -65,14 +59,6 @@ build() {
# Add freedo as boot logo
patch -Np1 -i "${srcdir}/boot-logo.patch"
- # fix broken watchdog
- # https://bugzilla.kernel.org/show_bug.cgi?id=44991
- patch -Np1 -i "${srcdir}/watchdog-3.5.x.patch"
-
- # fix i915 i2c crash
- # https://bugzilla.kernel.org/show_bug.cgi?id=46381
- patch -Np1 -i "${srcdir}/i915-i2c-crash-3.5.x.patch"
-
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
@@ -90,7 +76,7 @@ build() {
# https://git.kernel.org/?p=linux/hotplug/udev.git;a=blob_plain;f=README
# and make USB storage support builtin (e.g. for booting from USB
# disks without slowly loading an initramfs)
- sed -ri -e "s|CONFIG_MIPS32_N32=.*|CONFIG_MIPS32_N32=y|g" \
+ sed -ri \
-e "s|CONFIG_MIPS32_N32=.*|CONFIG_MIPS32_N32=y|g" \
-e "s|CONFIG_UEVENT_HELPER_PATH=.*|CONFIG_UEVENT_HELPER_PATH=\"\"|g" \
-e "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_localversionname}\"|g" \
@@ -154,7 +140,7 @@ build() {
_package() {
pkgdesc="The ${pkgbase} kernel and modules"
[ "${pkgbase}" = "linux-libre" ] && groups=('base')
- depends=('coreutils' 'kmod')
+ depends=('coreutils' 'linux-libre-firmware' 'kmod')
optdepends=('crda: to set the correct wireless channels of your country')
provides=("kernel26${_kernelname}=${pkgver}" "linux${_kernelname}=${pkgver}")
conflicts=("kernel26${_kernelname}" "kernel26-libre${_kernelname}" "linux${_kernelname}")