summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD36
1 files changed, 15 insertions, 21 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 15bb939d0..575edcbd7 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 178533 2013-02-25 11:02:32Z tpowa $
+# $Id: PKGBUILD 178913 2013-02-28 18:41:03Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): Nicolás Reynolds <fauno@kiwwwi.com.ar>
@@ -10,18 +10,17 @@
pkgbase=linux-libre # Build stock -LIBRE kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
_basekernel=3.8
-#_sublevel=9
-#pkgver=${_basekernel}.${_sublevel}
-pkgver=${_basekernel}
-pkgrel=2
-#_lxopkgver=${_basekernel}.8 # nearly always the same as pkgver
+_sublevel=1
+pkgver=${_basekernel}.${_sublevel}
+pkgrel=1
+_lxopkgver=${_basekernel}.0 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl')
options=('!strip')
source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gnu/linux-libre-${_basekernel}-gnu.tar.xz"
- #"http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${_basekernel}-gnu-${pkgver}-gnu.xz"
+ "http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${_basekernel}-gnu-${pkgver}-gnu.xz"
# the main kernel config files
'config.i686' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -30,22 +29,21 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'Kbuild.platforms'
'boot-logo.patch'
'change-default-console-loglevel.patch'
- 'CVE-2013-1763.patch')
- #"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
+ "http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
md5sums=('84c2a77910932ffc7d958744ac9cf2f5'
- '101e798e00fd9b66a4c86cd30d28b844'
- '5f3338af83af116b99746eb8a3ca65e4'
- 'e49ac236dfeef709f91a3d993ea7b62c'
+ 'd5ad2ecc865a32378517c3c07ca99173'
+ '4d73ccd0f1825a4bd474d4fead6c0d42'
+ 'e132184c6d02ef580a504967c067e1c5'
'2967cecc3af9f954ccc822fd63dca6ff'
'8267264d9a8966e57fdacd1fa1fc65c4'
'04b21c79df0a952c22d681dd4f4562df'
'9d3c56a4b999c8bfbd4018089a62f662'
'420991808fe4cba143013427c0737aa9')
-#if [ "$CARCH" != "mips64el" ]; then
-# # Don't use the Loongson-specific patches on non-mips64el arches.
-# unset source[${#source[@]}-1]
-# unset md5sums[${#md5sums[@]}-1]
-#fi
+if [ "$CARCH" != "mips64el" ]; then
+ # Don't use the Loongson-specific patches on non-mips64el arches.
+ unset source[${#source[@]}-1]
+ unset md5sums[${#md5sums[@]}-1]
+fi
_kernelname=${pkgbase#linux-libre}
_localversionname=-LIBRE
@@ -60,10 +58,6 @@ build() {
# Add freedo as boot logo
patch -Np1 -i "${srcdir}/boot-logo.patch"
- # Fix security vulnetability CVE-2013-1763.patch
- # https://bugs.archlinux.org/task/34005
- patch -Np1 -i "${srcdir}/CVE-2013-1763.patch"
-
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)