summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD86
1 files changed, 35 insertions, 51 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index f9d5e1b8a..e114173fa 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -14,20 +14,18 @@ _replacesoldkernels=() # '%' gets replaced with kernel suffix
_replacesoldmodules=() # '%' gets replaced with kernel suffix
pkgbase=linux-libre
-pkgver=5.17.3 # (x86_64 only - other arches need re-working)
+pkgver=5.17.8
pkgrel=1
pkgdesc='Linux-libre'
-rcnver=5.11.11
-rcnrel=armv7-x14
+rcnver=5.17.3
+rcnrel=armv7-x9
url='https://linux-libre.fsfla.org/'
arch=(i686 x86_64 armv7h)
license=(GPL2)
makedepends=(
bc libelf pahole cpio perl tar xz
xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick texlive-latexextra
- git
)
-makedepends=( ${makedepends[*]/git/} )
makedepends_armv7h=(uboot-tools vboot-utils dtc) # required by linux-libre-chromebook
options=('!strip')
_srcname=linux-5.17
@@ -46,27 +44,14 @@ source=(
# https://labs.parabola.nu/issues/877
# http://www.fsfla.org/pipermail/linux-libre/2015-November/003202.html
0002-fix-Atmel-maXTouch-touchscreen-support.patch
- # AUR 'linux-rc' patches
+ # Arch Linux patches
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- # the comment above is confusing - the arch 'linux' package has no patches
- # presumably these patches are taken from https://aur.archlinux.org/linux-rc.git/
- # some of them do not apply, and are not present in the 'linux-rc' 5.17.3 AUR repo
- # error:
- # Applying patch 0002-PCI-Add-more-NVIDIA-controllers-to-the-MSI-masking-q.patch...
- # patching file drivers/pci/quirks.c
- # Hunk #1 FAILED at 5802.
- # 1 out of 1 hunk FAILED -- saving rejects to file drivers/pci/quirks.c.rej
-# 0002-PCI-Add-more-NVIDIA-controllers-to-the-MSI-masking-q.patch
-# 0003-iommu-intel-do-deep-dma-unmapping-to-avoid-kernel-fl.patch
-# 0004-cpufreq-intel_pstate-ITMT-support-for-overclocked-sy.patch
-# 0005-Bluetooth-btintel-Fix-bdaddress-comparison-with-garb.patch
-# 0006-lg-laptop-Recognize-more-models.patch
- # so i replaced them with the patches from the 5.17.3 'linux-rc' 5.17.3 AUR repo
0002-random-treat-bootloader-trust-toggle-the-same-way-as.patch
0003-tick-Detect-and-fix-jiffies-update-stall.patch
0004-tick-rcu-Remove-obsolete-rcu_needs_cpu-parameters.patch
0005-tick-rcu-Stop-allowing-RCU_SOFTIRQ-in-idle.patch
0006-lib-irq_poll-Declare-IRQ_POLL-softirq-vector-as-ksof.patch
+ 0007-NFSv4.1-provide-mount-option-to-toggle-trunking-disc.patch
)
source_i686=(
# avoid using zstd compression in ultra mode (exhausts virtual memory)
@@ -78,13 +63,11 @@ source_armv7h=(
# Arch Linux ARM patches
0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch
0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch
- 0003-SMILE-Plug-device-tree-file.patch
- 0004-fix-mvsdio-eMMC-timing.patch
- 0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
- 0006-set-default-cubietruck-led-triggers.patch
- 0007-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
- 0008-ARM-dove-enable-ethernet-on-D3Plug.patch
- 0009-USB-Armory-MkII-support.patch
+ 0003-fix-mvsdio-eMMC-timing.patch
+ 0004-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
+ 0005-set-default-cubietruck-led-triggers.patch
+ 0006-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
+ 0007-USB-Armory-MkII-support.patch
# ChromiumOS patches
0001-CHROMIUM-block-partitions-efi-Add-support-for-IGNORE.patch
)
@@ -94,7 +77,7 @@ validpgpkeys=(
)
sha512sums=('565de7f956e40a931858cb29b61619f25fc57ce588b8762bef806e470d20bbbdf98a6e1c55eccae61a7365c0ecaae4825d81f7eec8689911710949ba5b34ce0c'
'SKIP'
- 'dac91c125a65ae7843206eda3d6cc7aaf6e3e8e07ef9348f336c0feb846a1285ea34d9cc3e547430a872da1064dcf22dbb1e2a0ed616de8c36c5da73fca790a2'
+ '71ba9ae3f75d72d2d86cc8cab1df463725e00088fb93b09553066a9b968d3a32abed77fac6011433377ac2970c8149a28e85ed25429da7dec56b47ba871cd4ae'
'SKIP'
'13cb5bc42542e7b8bb104d5f68253f6609e463b6799800418af33eb0272cc269aaa36163c3e6f0aacbdaaa1d05e2827a4a7c4a08a029238439ed08b89c564bb3'
'SKIP'
@@ -102,34 +85,33 @@ sha512sums=('565de7f956e40a931858cb29b61619f25fc57ce588b8762bef806e470d20bbbdf98
'SKIP'
'267295aa0cea65684968420c68b32f1a66a22d018b9d2b2c1ef14267bcf4cb68aaf7099d073cbfefe6c25c8608bdcbbd45f7ac8893fdcecbf1e621abdfe9ecc1'
'SKIP'
- '4d20c1d0eed64bc64ac04e41e10288259212e00bc0967887e20e5ae277735d3a036c0a5ded08276455d2748af5787ebcf910329491eb43e84c204d6a9d76065f'
- 'cf8aa9f4071f74f6cbd0314c8193f75b7e8bbb2caecb4b5b4c07d94eb61d9a70ed98ed0fc2db92ce9b4a796598b098e7cd0d171a660584e4da419870b329a599'
- '51e8b4da770067e8257d292622d865cb16ac57fdfd8967bdfb74efec197dae9eab958e5637a728640ae60885bdde41c06c8076227a4f83db0b752215f91f3a87'
+ 'b1f013835dcf521dcadb58ed22f271f7f01b3b15403924bd0076eb9ef4e8aa31f98b1b99d47ae726f8e981b3da44f1c484ce14e2030e31a67ad7c8eea55848d9'
+ '5a955a795f9f49d8617897300d3d03c431b1a6fa2bc9ed4106606617e4f16b28f94906498b13c24fd5c186c76a685e5f877013093184ae80435e7b86f52e8755'
+ '47d16ffc94510d4a8773146a46cfb35aca8cfdae38d17283334cd62d92de36250fbec90e9892357033398ecc7d970127b1a41b703a8372972422ca4af7c90c70'
'53103bf55b957b657039510527df0df01279dec59cda115a4d6454e4135025d4546167fa30bdc99107f232561c1e096d8328609ab5a876cf7017176f92ad3e0b'
- '167bc73c6c1c63931806238905dc44c7d87c5a5c0f6293159f2133dfe717fb44081018d810675716d1605ec7dff5e8333b87b19e09e2de21d0448e447437873b'
+ 'f10af02f0cb2d31259d9633e1ba845f555f525789f750fc2ddc51bd18c5ff64fcdd242dae801623887f5ce5cdb5528bce890459f0fab9fd31a28868bb7f6bba5'
'bb6718984a7357c9b00c37e4788480e5b8b75018c172ecc1441bc3fc5d2d42444eb5d8c7f9d2e3a7d6fed6d03acb565e3c0559486e494c40a7fe6bd0570c9ede'
'143dea30c6da00e504c99984a98a0eb2411f558fcdd9dfa7f607d6c14e9e7dffff9cb00121d9317044b07e3e210808286598c785ee854084b993ec9cb14d8232'
'02af4dd2a007e41db0c63822c8ab3b80b5d25646af1906dc85d0ad9bb8bbf5236f8e381d7f91cf99ed4b0978c50aee37cb9567cdeef65b7ec3d91b882852b1af'
'b8fe56e14006ab866970ddbd501c054ae37186ddc065bb869cf7d18db8c0d455118d5bda3255fb66a0dde38b544655cfe9040ffe46e41d19830b47959b2fb168'
- '5ad31d899fa56b49efb6eec6d721e85e1b723f65c83a9aaec52c3281f1862c7b0ccf5ddac077af669aa222b4818c4ddbc64f39739fc2946c5ddab49101ba0924'
- 'd4dff95d2f4eb790d51a7a8c74d8730d211df40f38f92c2ada484a124161412a28a48862fa785a3003958d9874ba7b167b49fb9edebd70928277e726d0c02962'
- '4514017c2d3e99e803052abe1fd90f3695fc0ea0630a25f52fc3994d77bc609d8c19dd302c1835b71fc13b917ab5cd25a27a1362ff42b99c089b61753b3c9220'
- '060f701a9923ca5cafa879c2547b9b7be8e1f8cd5ff2a7e9635d5013ebbda8f402658a1680cb2f70da0df67ee443e9cd18219bdfad80641171a7a6e1dc243964'
- '8d1507f6e32ab3dbf0ef22c3fcd6b116ed848431d0657166924bec46c7436991a5789ffc5ac8e1cbfb4e490deffe38a20000fc019c69d3087ba8337125e6339d'
- '7994f3777099a59f535026bfc25e2b23939cc01adc28d19b3cbc9fa642eb167eca50e62a1532afdd067393b5ae7b64758fbf0c6718b9f237c978fa180aa15c11')
-sha512sums_i686=('3a346ff5e0fdefafd28bc3dd0e4b6cd68e3f0014e59d1611d99f2edb8d074fd32649eeb0894a7e340e4f907b5cfc0e08e0753e0427a68dc113bb22835a892968')
-sha512sums_armv7h=('a4aa00ca3f03d524d3fb6379116c4e4e7908e7c30f6347f55be256c44d806d8db5f04c96369d5a725e45b7390e9fde842f388cdc5d5699d80ec5d1519f7367f4'
+ 'cf6a2987d5f27aaea040bd01ab82de0bc054f0b0747bf74a8fb57355ac5a1700a4d6ba91b0a8528e7f394694e98a768323c6657a109297b7b44fc7c5e82182de'
+ 'c8a22540dee3a005ebd2ab5f0230a744e493ba34efbd92cc817564f209f5db9c0719eeed49b03a0b5d75957bee8e369c14a4ebeb2cb776ff971ece8896178942'
+ 'e6787fa101be723e7828ad3f79e7334ba25f5c53b9a98fb3f32882b1f13c707d2382b9d142aad1457d68cdbadb6f12a8620f8e179ce97bd3cc88a7b709867ada'
+ '8173fa14d68bd5a88bfe1af22a584f0cf6afa442f3ed0f7df80e346c27eda9e45e4e965771158ed424d1ae1d0d18b7e91cc2b566ac859db48e5158846b4c848f'
+ '1f95f5824f869b6a307f0e11ac2a3a0b54f02eff30e0923e04ef75a9a7fa0b09da50cc6cdcdb69176cb419aba332869086225572ca857ee98cd1bf5c007aa92c'
+ 'c631403c2398271334b5815c0abdcc66c35a17f8f965f594fa3367088c84dd1062e6282a611ee87f8bafe5dbe19a302babde8307688fa09d393dd64b03142dff'
+ '782014cb1a5e7fc22dc92137c098438908182749b4f98a7db5edd7f068c1e7def229f4889ccbbadd1d0be96f4dc8e3e72e10b62d5c2e87d8f16595f811b8e309')
+sha512sums_i686=('bca15cc96f64c38adcd13a46752866b5b30555ac21e19b3f7afcd20fcb7ec585c9d990fe8f842f44d5f69d477d72867fe6a9102729f26f93f5a80b372e41ce85')
+sha512sums_armv7h=('8adea742801f797c1586671725631389d7d5fac9c4473a08136afba0647fa8076c9919f4802e06974e1a71c054a4b83f8200327c723d9479e8ed804ac6bd4e76'
'SKIP'
- 'b832287560c841e292d71be01c65045ee2ee6ac41f05176ebe349d730b5b79887bb629d176d5fd16a3e7ebb5e51de30b6d6fad6fad53821063188248bd1415bb'
- 'f997a0afaaffb66533168f5d9cc341871eb54feb88d6ce578e816add82596bedf4dc242510e171e1e5b56464cf701384a32ed916176ea0c2db24209d754d3c58'
- '96b97f6e721d179d88e7b4084ebb62ce30ddd13cbbcb367147e6646c8487107af36b3610d10e53abffae3a83736cdd7734e5dbcadb1909ced278f40a20302861'
- '14f3ef9f2211e98198e96bd4f91978720acd703ee778698b85916cef73c1aea648d1d08a075f2ed334f5c27b9933274fa0651401e0baa3570f389a20aaec54e8'
- 'b464e9af459c37c929ba30cdb7eb575038e970c9d91ff98fa37c0bc6161538b42a802dde34882772cf665130038158cb985fe06d65313f7c584c6c63045199d8'
- '9d8019b8f525d5614d476ac34a35a40e8e1994f444a686b561c57b8ae488fcc44ffca9d034cea7b2271a2b7a7fa3a2ba2fcaa452504c320eff0bc3fc4de64ed2'
- 'b3cf13c44b8b35bb7610206161a251cbf90299b0533e8e23465b9ae566feed510c5722aceadb7e2097de439362d0689de5692a091cbe8bec2994ef5290622095'
- '463d68de99f434fd3409ee620eaa7b648d6627c5a04cfeab65b91053129e71bf906db817fd9770297ae1e38f8a5a84be4d20a1d1717e6821478f2c1bbc416cb2'
- '813fbfb17659e4e7512367f03b06f9bc54070886f5e7206548deced60032f92d3ca0beb78416706662bf713cb0f7a5d8d81f8f08b911ca8254b417e82306d829'
- '7bda2ad7eb81af802873cb6764cb9c675ec50ceeb5adc487881ebc8c316cf55f836e56c2cc67494a2920e86494861db2eb924b7ff9b151ae3c5b0e493c373bf9')
+ '8da996a42249672893fa532ccbd096347580a0dc1698c45e9c865646e2765789553b1bb42793e721de30aea70340fdc116d2e4a50580fef999ca5fc627aaf4c3'
+ '0e6ddc24011d77a2e422b642c4507317fc2d26b20f5649818a2f11acac165ccab2cf2e64ab50d44ce7affcfe12c2ef5158790e499058831e7995400b2087df78'
+ '5d2f228151148358b07744a9c09cf6e2420c4284735d4ce7dc925a1deb3970298cc95dd766ee13e094e2853847b016c3ebc2d61bb423e370b4bc33938367ebda'
+ 'a206c3dc678839831d72eefee997cbe1bb877af7f6f90dfe5cab0bd7d9686a3b13a2aba74c8fbe5533872e12306ac9ea1b5eede18ef3cf10b8d01361afd67e9c'
+ 'a1072dd808c63592178cc01ea3c36de946f277fb451b13c34f51a5ac134cde4a8a4d57487132af1c6d7b5820842cdda9dc4edb3da85d33bd02bf87a032c3263a'
+ '85b2e16a930b8066990c42f973d386dc3c6d62fdf3d1289bbb51df3df296c26f30051162fba49a42d38f71f05de926aa8c065097f14bd8e9f8e28a52949ead00'
+ '2e99582d8b670b6c6b27add14b60e957cbcf9cd6aae40491bd9dea6ac455c0ade0bbee21e3bdfb5e06ce83ad27c5a788404b05bf7ac93831ca18d2e60a67017c'
+ '5b77c587cf2ffb60acf1d9eb43330983548c7e81a53e0ffd2b04962a99441a0000d631ff77c245c7062afc2c8368d996a2456496d42dcb658f330e5083e5e029')
_replacesarchkernel=("${_replacesarchkernel[@]/\%/${pkgbase#linux-libre}}")
_replacesoldkernels=("${_replacesoldkernels[@]/\%/${pkgbase#linux-libre}}")
@@ -270,7 +252,9 @@ _package-headers() {
cp -t "$builddir" -a scripts
# required when STACK_VALIDATION is enabled
- install -Dt "$builddir/tools/objtool" tools/objtool/objtool
+ if [[ -e tools/objtool/objtool ]]; then
+ install -Dt "$builddir/tools/objtool" tools/objtool/objtool
+ fi
# required when DEBUG_INFO_BTF_MODULES is enabled
install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids