summaryrefslogtreecommitdiff
path: root/libre/linux-libre-pck/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre-pck/PKGBUILD')
-rw-r--r--libre/linux-libre-pck/PKGBUILD60
1 files changed, 45 insertions, 15 deletions
diff --git a/libre/linux-libre-pck/PKGBUILD b/libre/linux-libre-pck/PKGBUILD
index 2f03ad86f..324b3542b 100644
--- a/libre/linux-libre-pck/PKGBUILD
+++ b/libre/linux-libre-pck/PKGBUILD
@@ -13,18 +13,18 @@ _replacesoldkernels=()
_replacesoldmodules=()
pkgbase=linux-libre-pck
-pkgver=5.15.13.pck1
+pkgver=5.17.8.pck1
pkgrel=1
pkgdesc='Linux-libre PCK'
url='https://wiki.parabola.nu/PCK'
arch=(i686 x86_64 armv7h)
license=(GPL2)
makedepends=(
- bc kmod libelf pahole cpio perl tar xz
- xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
+ bc libelf pahole cpio perl tar xz
+ xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick texlive-latexextra
)
options=('!strip')
-_srcname=linux-5.15
+_srcname=linux-5.17
source=(
"https://linux-libre.fsfla.org/pub/linux-libre/releases/${_srcname##*-}-gnu/linux-libre-${_srcname##*-}-gnu.tar.xz"{,.sign}
"https://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver%.*}-gnu/patch-${_srcname##*-}-gnu-${pkgver%.*}-gnu.xz"{,.sign}
@@ -32,20 +32,25 @@ source=(
config.i686 config.x86_64 config.armv7h # the main kernel config files
linux-armv7h.preset # armv7h preset file for mkinitcpio ramdisk
)
+source_i686=(
+ # avoid using zstd compression in ultra mode (exhausts virtual memory)
+ no-ultra-zstd.patch
+)
validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
'6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
)
-sha512sums=('3c586054285ea0cb4d1a1ff257757d092db80c2413dcec6e58c63b22490d42b8f2c441cee62839603599d5ad75fbd7560bf51ec6c2f3ab9354adae0c2c7234e5'
+sha512sums=('565de7f956e40a931858cb29b61619f25fc57ce588b8762bef806e470d20bbbdf98a6e1c55eccae61a7365c0ecaae4825d81f7eec8689911710949ba5b34ce0c'
'SKIP'
- '5a5bf2db2f274b7b31d2d7dcae5de7299023f8b5ba898512aa39f57663897501a6f6293e287093baa09405a5e28a8218e61fee7b1d553ad5d05940d4d799b3b0'
+ '71ba9ae3f75d72d2d86cc8cab1df463725e00088fb93b09553066a9b968d3a32abed77fac6011433377ac2970c8149a28e85ed25429da7dec56b47ba871cd4ae'
'SKIP'
- '1cc2038d835c0031ceed93babc83867b419c2d758f81e903f25565fe4b392427d8f41901be9743be4e7f613b3dcd3ac0343bce75581157f4e74eb565661864b4'
+ 'df322ff9c3fad418e875f8827cdd0a8f6a13a55c4656b87300f6a592ba56724e30c303ed94eb2d69eb95379c3c643ee5ff84771a03911efae7e212b8fa5d48bd'
'SKIP'
- 'eb0305cb2f50bf9f23774677e2111268f934d12f4f0170eb9e5b6c8afd7a732c7c4b9468684dbfa8aaf267ef970350fb0bd0aa08c9fdfc58e0cbbfea0edcd97c'
- '022815fe38bd9aa75ae08e1b1d92ac4141ea9dfb730ce77c709df658bab910611220dbbae441b1beef2e432f9b79460f5a98b62f4e2d65f0629818b0208a2c40'
- '6728253ca04a603ef35ceb06b284c509d8ffda6a8c6403fe687afe5d956425588ebbd62bfc5dd1d7fd9a03071a30c7cd86ac72a1fd67cbbf1ebdac85ee703caf'
+ '50de63086aef1cd4278fc7088ae537ae6eb4994a4e8d09edbc957ff90e7232b85ce37928117589a1a619ded90eb584b770579e6efc5d5b2cc3e4f6c6cd96a71a'
+ 'f18d743a28afde8af4701853dfb59bfe6f3789756f9ffa3658cb2c75a8af59cd30ae125b74882529ad81b2c399e42ea56fabdc1e4354d5ce2b84d8ac2d96a51f'
+ '51b697e07fa8c8df390e329e1ac0ca50a0b255ffcb3eb3dc224c01d64e0113f05b804215cdc2a67cd43f91c88a84001af2f0c00fcf2f1ad932216100d28e7eff'
'53103bf55b957b657039510527df0df01279dec59cda115a4d6454e4135025d4546167fa30bdc99107f232561c1e096d8328609ab5a876cf7017176f92ad3e0b')
+sha512sums_i686=('bca15cc96f64c38adcd13a46752866b5b30555ac21e19b3f7afcd20fcb7ec585c9d990fe8f842f44d5f69d477d72867fe6a9102729f26f93f5a80b372e41ce85')
_replacesarchkernel=("${_replacesarchkernel[@]/\%/${pkgbase#linux-libre}}")
_replacesoldkernels=("${_replacesoldkernels[@]/\%/${pkgbase#linux-libre}}")
@@ -73,6 +78,28 @@ prepare() {
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux-libre}" > localversion.20-pkgname
+ if [ "$CARCH" = "armv7h" ]; then
+ local src_armv7h
+ for src_armv7h in "${source_armv7h[@]}"; do
+ src_armv7h="${src_armv7h%%::*}"
+ src_armv7h="${src_armv7h##*/}"
+ [[ $src_armv7h = *.patch ]] || continue
+ echo "Applying patch $src_armv7h..."
+ patch -Np1 < "../$src_armv7h"
+ done
+ fi
+
+ if [ "$CARCH" = "i686" ]; then
+ local src_i686
+ for src_i686 in "${source_i686[@]}"; do
+ src_i686="${src_i686%%::*}"
+ src_i686="${src_i686##*/}"
+ [[ $src_i686 = *.patch ]] || continue
+ echo "Applying patch $src_i686..."
+ patch -Np1 < "../$src_i686"
+ done
+ fi
+
local src
for src in "${source[@]}"; do
src="${src%%::*}"
@@ -100,7 +127,7 @@ build() {
_package() {
pkgdesc="The $pkgdesc kernel and modules"
depends=(coreutils kmod initramfs)
- optdepends=('crda: to set the correct wireless channels of your country'
+ optdepends=('wireless-regdb: to set the correct wireless channels of your country'
'linux-libre-firmware: firmware images needed for some devices')
provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE VHBA-MODULE)
provides+=("${_replacesarchkernel[@]/%/=${pkgver//pck/zen}}" "LINUX-ABI_VERSION=${pkgver%.*}")
@@ -120,7 +147,8 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
rm "$modulesdir"/{source,build}
@@ -157,13 +185,15 @@ _package-headers() {
fi
cp -t "$builddir" -a scripts
- # add objtool for external module building and enabled VALIDATION_STACK option
+ # required when STACK_VALIDATION is enabled
if [[ -e tools/objtool/objtool ]]; then
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
fi
- # add xfs and shmem for aufs building
- mkdir -p "$builddir"/{fs/xfs,mm}
+ # required when DEBUG_INFO_BTF_MODULES is enabled
+ if [[ -e tools/bpf/resolve_btfids/resolve_btfids ]]; then
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
+ fi
echo "Installing headers..."
cp -t "$builddir" -a include