summaryrefslogtreecommitdiff
path: root/libre/linux-libre-pae/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre-pae/PKGBUILD')
-rw-r--r--libre/linux-libre-pae/PKGBUILD50
1 files changed, 28 insertions, 22 deletions
diff --git a/libre/linux-libre-pae/PKGBUILD b/libre/linux-libre-pae/PKGBUILD
index fea968c5f..a80aacee4 100644
--- a/libre/linux-libre-pae/PKGBUILD
+++ b/libre/linux-libre-pae/PKGBUILD
@@ -9,18 +9,18 @@ _replacesoldkernels=() # '%' gets replaced with kernel suffix
_replacesoldmodules=() # '%' gets replaced with kernel suffix
pkgbase=linux-libre-pae
-pkgver=5.15.12
+pkgver=5.17.9
pkgrel=1
pkgdesc='Linux-libre PAE (physical address extension)'
url='https://linux-libre.fsfla.org/'
arch=(i686)
license=(GPL2)
makedepends=(
- bc kmod libelf pahole cpio perl tar xz
- xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
+ bc libelf pahole cpio perl tar xz
+ xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick texlive-latexextra
)
options=('!strip')
-_srcname=linux-5.15
+_srcname=linux-5.17
source=(
"https://linux-libre.fsfla.org/pub/linux-libre/releases/${_srcname##*-}-gnu/linux-libre-${_srcname##*-}-gnu.tar.xz"{,.sign}
"https://linux-libre.fsfla.org/pub/linux-libre/releases/$pkgver-gnu/patch-${_srcname##*-}-gnu-$pkgver-gnu.xz"{,.sign}
@@ -36,19 +36,22 @@ source=(
0002-fix-Atmel-maXTouch-touchscreen-support.patch
# Arch Linux patches
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-PCI-Add-more-NVIDIA-controllers-to-the-MSI-masking-q.patch
- 0003-iommu-intel-do-deep-dma-unmapping-to-avoid-kernel-fl.patch
- 0004-cpufreq-intel_pstate-ITMT-support-for-overclocked-sy.patch
- 0005-Bluetooth-btintel-Fix-bdaddress-comparison-with-garb.patch
- 0006-lg-laptop-Recognize-more-models.patch
+ 0002-random-treat-bootloader-trust-toggle-the-same-way-as.patch
+ 0003-tick-Detect-and-fix-jiffies-update-stall.patch
+ 0004-tick-rcu-Remove-obsolete-rcu_needs_cpu-parameters.patch
+ 0005-tick-rcu-Stop-allowing-RCU_SOFTIRQ-in-idle.patch
+ 0006-lib-irq_poll-Declare-IRQ_POLL-softirq-vector-as-ksof.patch
+ 0007-NFSv4.1-provide-mount-option-to-toggle-trunking-disc.patch
+ # Arch Linux 32 patches
+ no-ultra-zstd.patch
)
validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
'6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
)
-sha512sums=('3c586054285ea0cb4d1a1ff257757d092db80c2413dcec6e58c63b22490d42b8f2c441cee62839603599d5ad75fbd7560bf51ec6c2f3ab9354adae0c2c7234e5'
+sha512sums=('565de7f956e40a931858cb29b61619f25fc57ce588b8762bef806e470d20bbbdf98a6e1c55eccae61a7365c0ecaae4825d81f7eec8689911710949ba5b34ce0c'
'SKIP'
- '80a0d8903c6ee462f966e3360d22f4894dc69239c99ef28d62a1ea6643008580a368b61cee5e6691f2bbf0ff162fb10e13ca31904ab89a5e679f91ae9860999b'
+ '921c4e1eca023c3a0f756ec788188e0d8c5b0622c832516c32e87f964e90769c7072f41785f1bfde1344fcd829332834a959313fd4db69cab20227eeba4141aa'
'SKIP'
'13cb5bc42542e7b8bb104d5f68253f6609e463b6799800418af33eb0272cc269aaa36163c3e6f0aacbdaaa1d05e2827a4a7c4a08a029238439ed08b89c564bb3'
'SKIP'
@@ -56,15 +59,17 @@ sha512sums=('3c586054285ea0cb4d1a1ff257757d092db80c2413dcec6e58c63b22490d42b8f2c
'SKIP'
'267295aa0cea65684968420c68b32f1a66a22d018b9d2b2c1ef14267bcf4cb68aaf7099d073cbfefe6c25c8608bdcbbd45f7ac8893fdcecbf1e621abdfe9ecc1'
'SKIP'
- '06ffff3688453ee5c67a6b47fa2deb26e0cba04cad7d44f345ce227fcc4049000565158e1e0fe00c88120a3e4c60d7b418ce7c7585893f0769ba14aae8379106'
+ '55fdec0555ef18aaaba22ff6cdad477c6c80b5dd3b0477b39e7099b3838376f8c3b42e44f579758d8e764d5a4750f6fc8378e2d5b05536cdebb17c13f734c695'
'02af4dd2a007e41db0c63822c8ab3b80b5d25646af1906dc85d0ad9bb8bbf5236f8e381d7f91cf99ed4b0978c50aee37cb9567cdeef65b7ec3d91b882852b1af'
'b8fe56e14006ab866970ddbd501c054ae37186ddc065bb869cf7d18db8c0d455118d5bda3255fb66a0dde38b544655cfe9040ffe46e41d19830b47959b2fb168'
- '5ad31d899fa56b49efb6eec6d721e85e1b723f65c83a9aaec52c3281f1862c7b0ccf5ddac077af669aa222b4818c4ddbc64f39739fc2946c5ddab49101ba0924'
- 'c12a450a5026216676bd5728b43e04641d28a0eacd916e9304b6c38b03699005cf74ed8d3e4de67cab73f47cdaef728fdb1f75b3b1e5221cfc62c2a37e52ff67'
- '65f4ecc64551d3e644fb6e95ed70dcb694aedd58fc6bed694a912c6d89bfdfd2382d1f20c3b79c0a9e6f5c479efe7e950e47f88b10925ac71276e4cad94ab07e'
- '5b052dfc8f62ac2f86b1a08620109ec06154273a67ef011b18d38f7098b5b42026da2a8ba79a9234d10766bc00f740a2ce900552806a49937b7e33a35bca2809'
- '6f139510d047cf0f915daded5221ea4cf2551ebb50c7350965ba417b9b2d0df8796e0508d772cdc6d50cdc5b8c1d8589ace86d6e7a779ea2abed0013696396a3'
- 'e54423a3f0162f76cd211706c48f05f4fd96ea99453ca84821018947dd05b3d1bb943c8ba9e5ce190d237663136122601e7edfe50540fef24ab16c813c6a02e1')
+ '9543379c1feba5585196396cc3ca6b9b957b967bdac29c502867ffb502743e1793c4a9ccdca4c30226120793df7bf887fb0cdf365d9304594777c16a0addd63b'
+ '37719ac336936ba70ef58d63e409a3df36a06f885205595ee55a20bdb6a801c698cb5412fa19398f375c111634713c4bee1619bf08429830ab02ff5fe257ef6c'
+ '44acd1454ad7faa4e993597bff67899a14e85e030f948db8590d12fc4eb05fb732e53e9a96bb59972ec319e54c160bbbee7c1568cdc199342afa4088b4a5eee3'
+ '0e1ea62e127883826655fa74c232ef3b8537fe0a1a2c7b89a710f43ce0b7b483e1b5bc14fa44cffae5aaadfd9c5b88b5e326d5feca9bf2fb922844bd6309f855'
+ '0c40c8a99e202dd869c54964495fd8005efbbd74679901bd976fa297b8d65554a8071345da3b171ef95d7fd2515588d05f09cf2ca6c86b0bcc9ff0468c997482'
+ 'b0c2bef3e76a25640539a6814bf8a120d000995d1d88c80b667b9bd1e489a452da47ee01b96cd0104f0a7627d5ff7ff916506f137f6cd6fb4df4f666bf2d92be'
+ '251d94b05ba7b252eef738efd8a5d75ec26df11bcd4e99b468db89cb370f56cc56e949b2fb1a7d00c61ded49fa0e0355551ea98f46662d4220cddacf5640e40b'
+ 'bca15cc96f64c38adcd13a46752866b5b30555ac21e19b3f7afcd20fcb7ec585c9d990fe8f842f44d5f69d477d72867fe6a9102729f26f93f5a80b372e41ce85')
_replacesarchkernel=("${_replacesarchkernel[@]/\%/${pkgbase#linux-libre}}")
_replacesoldkernels=("${_replacesoldkernels[@]/\%/${pkgbase#linux-libre}}")
@@ -118,7 +123,7 @@ build() {
_package() {
pkgdesc="The $pkgdesc kernel and modules"
depends=(coreutils kmod initramfs)
- optdepends=('crda: to set the correct wireless channels of your country'
+ optdepends=('wireless-regdb: to set the correct wireless channels of your country'
'linux-libre-firmware: firmware images needed for some devices')
provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
provides+=("${_replacesarchkernel[@]/%/=${pkgver%.*}}" "LINUX-ABI_VERSION=${pkgver%.*}")
@@ -138,7 +143,8 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
rm "$modulesdir"/{source,build}
@@ -162,8 +168,8 @@ _package-headers() {
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile_32.cpu
cp -t "$builddir" -a scripts
- # add xfs and shmem for aufs building
- mkdir -p "$builddir"/{fs/xfs,mm}
+ # required when DEBUG_INFO_BTF_MODULES is enabled
+ # install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
echo "Installing headers..."
cp -t "$builddir" -a include