summaryrefslogtreecommitdiff
path: root/libre/linux-libre-lts/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre-lts/PKGBUILD')
-rw-r--r--libre/linux-libre-lts/PKGBUILD66
1 files changed, 41 insertions, 25 deletions
diff --git a/libre/linux-libre-lts/PKGBUILD b/libre/linux-libre-lts/PKGBUILD
index f01cff8ba..ef9cba727 100644
--- a/libre/linux-libre-lts/PKGBUILD
+++ b/libre/linux-libre-lts/PKGBUILD
@@ -9,30 +9,28 @@
# Based on linux-lts package
-# NOTE: Don't build htmldocs due to an error in sphinx (armv7h only)
-
_replacesarchkernel=('linux%') # '%' gets replaced with kernel suffix
_replacesoldkernels=() # '%' gets replaced with kernel suffix
_replacesoldmodules=() # '%' gets replaced with kernel suffix
pkgbase=linux-libre-lts
-pkgver=5.10.89
+pkgver=5.15.41
pkgrel=1
pkgdesc='LTS Linux-libre'
-rcnver=5.10.83
-rcnrel=armv7-x58
+rcnver=5.15.32
+rcnrel=armv7-x23-parabola1
url='https://linux-libre.fsfla.org/'
arch=(i686 x86_64 armv7h)
license=(GPL2)
makedepends=(
- bc kmod libelf pahole cpio perl tar xz
- xmlto python-sphinx python-sphinx_rtd_theme python-six graphviz imagemagick
+ bc libelf pahole cpio perl tar xz
+ xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick texlive-latexextra
)
options=('!strip')
-_srcname=linux-5.10
+_srcname=linux-5.15
source=(
- "https://linux-libre.fsfla.org/pub/linux-libre/releases/${_srcname##*-}-gnu1/linux-libre-${_srcname##*-}-gnu1.tar.xz"{,.sign}
- "https://linux-libre.fsfla.org/pub/linux-libre/releases/$pkgver-gnu1/patch-${_srcname##*-}-gnu1-$pkgver-gnu1.xz"{,.sign}
+ "https://linux-libre.fsfla.org/pub/linux-libre/releases/${_srcname##*-}-gnu/linux-libre-${_srcname##*-}-gnu.tar.xz"{,.sign}
+ "https://linux-libre.fsfla.org/pub/linux-libre/releases/$pkgver-gnu/patch-${_srcname##*-}-gnu-$pkgver-gnu.xz"{,.sign}
"https://repo.parabola.nu/other/linux-libre/logos/logo_linux_"{clut224.ppm,vga16.ppm,mono.pbm}{,.sig}
config.i686 config.x86_64 config.armv7h # the main kernel config files
linux-armv7h.preset # armv7h preset file for mkinitcpio ramdisk
@@ -46,6 +44,11 @@ source=(
0002-fix-Atmel-maXTouch-touchscreen-support.patch
# Arch Linux patches
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
+ 0002-PCI_Add_more_NVIDIA_controllers_to_the_MSI_masking_quirk.patch
+ 0003-iommu_intel_do_deep_dma-unmapping_to_avoid_kernel-flooding.patch
+ 0004-Bluetooth_btintel_Fix_bdaddress_comparison_with_garbage_value.patch
+ 0005-lg-laptop_Recognize_more_models.patch
+ 0006_fix_NFSv4_mount_regression.diff
)
source_i686=(
# avoid using zstd compression in ultra mode (exhausts virtual memory)
@@ -59,9 +62,9 @@ validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
'6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
)
-sha512sums=('4bf48611e8a217931c2347f1aa3257da5ba210f263fb35edef43e935fd3fcab5333fc884198fe6ab180cc11ed11dd48b71dff4071b85f18830a6bf9e1c2cf97f'
+sha512sums=('3c586054285ea0cb4d1a1ff257757d092db80c2413dcec6e58c63b22490d42b8f2c441cee62839603599d5ad75fbd7560bf51ec6c2f3ab9354adae0c2c7234e5'
'SKIP'
- 'c09d808befd38f246c8f3224fee702a389fa6456aff6b8d5ba86f55e3647e1473cba4e43f4095a6d97d98f5474dc791ce5008de58003c9419b12cee517f6cb88'
+ '1e3c1db11bb929aad451f471a76a9b6b2df57bf9406bc0e9c21843710cf044cd8fc69c188f828170217a59babebc11fb009be6285408c6191c7ba07bb4d99703'
'SKIP'
'13cb5bc42542e7b8bb104d5f68253f6609e463b6799800418af33eb0272cc269aaa36163c3e6f0aacbdaaa1d05e2827a4a7c4a08a029238439ed08b89c564bb3'
'SKIP'
@@ -69,15 +72,20 @@ sha512sums=('4bf48611e8a217931c2347f1aa3257da5ba210f263fb35edef43e935fd3fcab5333
'SKIP'
'267295aa0cea65684968420c68b32f1a66a22d018b9d2b2c1ef14267bcf4cb68aaf7099d073cbfefe6c25c8608bdcbbd45f7ac8893fdcecbf1e621abdfe9ecc1'
'SKIP'
- '161302c378c95fe95d8c9f3aae9b673f1555068495eb50e13cec69da023276c08b603a3bec909d70ecc31631bb15ceabc8def654ca2f2b1cad883c6a74306b7d'
- '58bf82d41b28741edd5170dfb42a055888834d6a4afe0372f21fc5b233baffc3b0f83fdd44e2b80b900eda87ac89d7703f6a9af7460481f9c947df6d19602907'
- '6012fa7b97c15ada82f0c205ea983bebac8b672ca498e22f524d219bdd8715784b24ce7d457803e8221a945c3daff95c4e467f70a420b9c2aa95d627f2d160a9'
+ '77c635568092ced8298b17ee03dc084ad926b2d9b29b595acacc09df887cbd1d57bff988f095b1b618dcc39e511b044d129de19a45b3b38398c5f432733b9b09'
+ 'f37400fd78d966e5ac698de2187f8ad1982a7916cd8cf385a27341db49900e1cb8853275a5f768026af5ae92036ee63f6252688ab2c9d5560b923fee113471e8'
+ 'f3e5a4e1a8f335570427acc08ee16e834312c6df91ef872533d34d299a6ea1ce46dae4151d9e3e1b1728d8c6d0210276c3d6743a92728dc7a6e00db5b8b5640e'
'53103bf55b957b657039510527df0df01279dec59cda115a4d6454e4135025d4546167fa30bdc99107f232561c1e096d8328609ab5a876cf7017176f92ad3e0b'
'02af4dd2a007e41db0c63822c8ab3b80b5d25646af1906dc85d0ad9bb8bbf5236f8e381d7f91cf99ed4b0978c50aee37cb9567cdeef65b7ec3d91b882852b1af'
'b8fe56e14006ab866970ddbd501c054ae37186ddc065bb869cf7d18db8c0d455118d5bda3255fb66a0dde38b544655cfe9040ffe46e41d19830b47959b2fb168'
- 'aed7844c51ec705ef1ef5d9f1adf27939073c99d4fcc97051bed2fba1ec161fdde4c57cbe039209fb86c72918493bea55ed26189c1dda3dbea3a3a7019363818')
+ '71de593fa8673e06b90284ea1fe337dff64f0b49477aa2da35d3026457e566c0e08090ae5412b711037cbd66ebc34d9c656ff6d3bbc8ecfd13956b166d2fe589'
+ '93b7328fea9046c61f22e4d2a9ac59b5c2181d603ba02024e40cbd2b3970f7c716726f46e789a77185302c10d09fbe35db5333bfc8f20a9f540d49439c6bd69b'
+ 'c6ce8e2214cd6a2c664e5e28aea29aea5ccdc07cf73239c5f06dec36121c503543a122cf7455ab6932f3d3c4dd97d0d3f03cc12f660c2541efe7a737dd38883a'
+ '606af0fd746e6a31463bcc561bc24a5595334fdb59cb6658095a9724f2645f53e8c36c6a353f8c46f3731544ea296ceacf093e077499589b49e7765682fd32ff'
+ '670843b65e762602785f6906d55af47ad4fc04f9a0d229fe59fcd0c9c6fd219e55b484c1be4e0989aaf1efa4e00136a38d4b3f354b5bd1dabe41efbefd9dc6e4'
+ 'f7c051fb8e334ab5f6aa40a381c8626e1f5dae5ce311c27b4a1737fa75a4b17e05c243833f2af5322cef7e9fe3f3fa46cb91be1cff8ebfc787f5c27444b3d1f4')
sha512sums_i686=('3a346ff5e0fdefafd28bc3dd0e4b6cd68e3f0014e59d1611d99f2edb8d074fd32649eeb0894a7e340e4f907b5cfc0e08e0753e0427a68dc113bb22835a892968')
-sha512sums_armv7h=('1744202d19e9cc501d80373f734e9c9715ccdb1723d72abd9fa6fb47cfd5d60157fb4ae95d2cbfe38296c4428df304f8ca290ad232a21804744b702b0783cada'
+sha512sums_armv7h=('c7f8995a741181de687b96ef959a3d16df06d2892e3d25811f0c8691d5cb168af8a89ad903c1511fe859b1efbf84870b3445a42c805de772ed5bcef8543d960b'
'SKIP')
_replacesarchkernel=("${_replacesarchkernel[@]/\%/${pkgbase#linux-libre}}")
@@ -98,13 +106,17 @@ prepare() {
if [ "${_srcname##*-}" != "$pkgver" ]; then
echo "Applying upstream patch..."
- patch -Np1 < "../patch-${_srcname##*-}-gnu1-$pkgver-gnu1"
+ patch -Np1 < "../patch-${_srcname##*-}-gnu-$pkgver-gnu"
fi
echo "Adding freedo as boot logo..."
install -m644 -t drivers/video/logo \
../logo_linux_{clut224.ppm,vga16.ppm,mono.pbm}
+ # fix NFSv4 mounting issue regression - FS#73838 / FS#73860
+ # https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/patch/?id=6f2836341d8a39e1e000572b10959347d7e61fd9
+ patch -Rp1 -i ../0006_fix_NFSv4_mount_regression.diff
+
echo "Setting version..."
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
@@ -144,6 +156,7 @@ prepare() {
echo "Setting config..."
cp ../config.$CARCH .config
make olddefconfig
+# diff -u ../config .config || :
#return 1
make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
@@ -152,15 +165,13 @@ prepare() {
build() {
cd $_srcname
make all
- if ! [ "$CARCH" = armv7h ]; then
- make htmldocs
- fi
+ make htmldocs
}
_package() {
pkgdesc="The $pkgdesc kernel and modules"
depends=(coreutils kmod initramfs)
- optdepends=('crda: to set the correct wireless channels of your country'
+ optdepends=('wireless-regdb: to set the correct wireless channels of your country'
'linux-libre-firmware: firmware images needed for some devices')
provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
replaces=(wireguard-lts)
@@ -181,7 +192,8 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
rm "$modulesdir"/{source,build}
@@ -200,6 +212,7 @@ _package() {
_package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
+ depends=(pahole)
provides=("${_replacesarchkernel[@]/%/-headers=$pkgver}")
conflicts=("${_replacesarchkernel[@]/%/-headers}" "${_replacesoldkernels[@]/%/-headers}")
replaces=("${_replacesarchkernel[@]/%/-headers}" "${_replacesoldkernels[@]/%/-headers}")
@@ -245,14 +258,17 @@ _package-headers() {
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
- # http://bugs.archlinux.org/task/13146
+ # https://bugs.archlinux.org/task/13146
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
- # http://bugs.archlinux.org/task/20402
+ # https://bugs.archlinux.org/task/20402
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
+ # https://bugs.archlinux.org/task/71392
+ install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
+
echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;