summaryrefslogtreecommitdiff
path: root/libre/linux-libre-grsec/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre-grsec/PKGBUILD')
-rw-r--r--libre/linux-libre-grsec/PKGBUILD41
1 files changed, 11 insertions, 30 deletions
diff --git a/libre/linux-libre-grsec/PKGBUILD b/libre/linux-libre-grsec/PKGBUILD
index 392e2fae1..5dacbe4f2 100644
--- a/libre/linux-libre-grsec/PKGBUILD
+++ b/libre/linux-libre-grsec/PKGBUILD
@@ -11,14 +11,14 @@
pkgbase=linux-libre-grsec # Build stock -LIBRE-GRSEC kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
-_basekernel=3.14
-_sublevel=8
+_basekernel=3.15
+_sublevel=1
_grsecver=3.0
-_timestamp=201406220132
+_timestamp=201406222112
_pkgver=${_basekernel}.${_sublevel}
pkgver=${_basekernel}.${_sublevel}.${_timestamp}
-pkgrel=1
-_lxopkgver=${_basekernel}.8 # nearly always the same as pkgver
+pkgrel=2
+_lxopkgver=${_basekernel}.1 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="https://grsecurity.net/"
license=('GPL2')
@@ -36,31 +36,23 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'Kbuild.platforms'
'boot-logo.patch'
'change-default-console-loglevel.patch'
- '0001-Bluetooth-allocate-static-minor-for-vhci.patch'
- '0002-module-allow-multiple-calls-to-MODULE_DEVICE_TABLE-p.patch'
- '0003-module-remove-MODULE_GENERIC_TABLE.patch'
- '0006-genksyms-fix-typeof-handling.patch'
'0012-fix-saa7134.patch'
'sysctl.conf'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.xz")
-sha256sums=('477555c709b9407fe37dbd70d3331ff9dde1f9d874aba2741f138d07ae6f281b'
- '325431cbfe7e2c7f9f956bc7b55ca47b7d20e1eea0e809c1190ac441b4a177bf'
- '61336d54f8e8426c564676a756114bd5cfe7125c90b2c710a6fed660517e2bcf'
+sha256sums=('93450dc189131b6a4de862f35c5087a58cc7bae1c24caa535d2357cc3301b688'
+ '1016625bbc6e408e2f055ec1d814c2b2975dcb278e8f5f49189490299f446611'
+ '24835ddd8b524b11d1179697052a3d669efcaef56a254ba384c73ef77ebd4b13'
'SKIP'
- '43388ea6e769794b087618e9714b850e02d67b29e9d3a1866290aba1b5831bf5'
- 'e217c311cac8328b501377621a179f2ea23196dc15035f39f6bd50aad7d08d8b'
+ '20d7aa7723620bcdefc0828c2ba0c5b17049e7ecb8475703ddccd9f3e84c30d7'
+ '6a9e7a0bd92f04379566809e4d1d677f690b4e49dcb841d8f7bff69782879f2a'
'9d2f34f1a8c514a7117b9b017a1f7312fb351f4d0b079eed102f89361534d486'
'c5451d5e1eafc4f8d28b1a2958ec3102c124433a414a86450fc32058e004156b'
'55bf07738a3286168a7929ae16dbca29defd14e77b9d24c487ae4c3d12bb9eb9'
'f913384dd6dbafca476fcf4ccd35f0f497dda5f3074866022facdb92647771f6'
'faced4eb4c47c4eb1a9ee8a5bf8a7c4b49d6b4d78efbe426e410730e6267d182'
- '6d72e14552df59e6310f16c176806c408355951724cd5b48a47bf01591b8be02'
- '52dec83a8805a8642d74d764494acda863e0aa23e3d249e80d4b457e20a3fd29'
- '65d58f63215ee3c5f9c4fc6bce36fc5311a6c7dbdbe1ad29de40647b47ff9c0d'
- 'cf2e7a2d00787f754028e7459688c2755a406e632ce48b60952fa4ff7ed6f4b7'
'79359454c9d8446eb55add2b1cdbf8332bd67dafb01fefb5b1ca090225f64d18'
'763f9323cdefc9ddf74ffeffd856f9eaec4d8d4ef702c88ee1aab429c2d0b389'
- 'cdc0c5b019689444d21607b39031c8473140a44df40ea4101aaefba6af78b03e')
+ 'f769db2fa56c7cba2c62ff52071dbf46a46a817ad39ec4d62bc2cecff3911954')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -92,17 +84,6 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
- # Fix vhci warning in kmod (to restore every kernel maintainer's sanity)
- patch -p1 -i "${srcdir}/0001-Bluetooth-allocate-static-minor-for-vhci.patch"
-
- # Fix atkbd aliases
- patch -p1 -i "${srcdir}/0002-module-allow-multiple-calls-to-MODULE_DEVICE_TABLE-p.patch"
- patch -p1 -i "${srcdir}/0003-module-remove-MODULE_GENERIC_TABLE.patch"
-
- # Fix generation of symbol CRCs
- # http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=dc53324060f324e8af6867f57bf4891c13c6ef18
- patch -p1 -i "${srcdir}/0006-genksyms-fix-typeof-handling.patch"
-
# fix saa7134 video
# https://bugs.archlinux.org/task/39904
# https://bugzilla.kernel.org/show_bug.cgi?id=73361