summaryrefslogtreecommitdiff
path: root/libre/linux-libre-grsec/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre-grsec/PKGBUILD')
-rw-r--r--libre/linux-libre-grsec/PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/libre/linux-libre-grsec/PKGBUILD b/libre/linux-libre-grsec/PKGBUILD
index e61a4ee6e..2041f3005 100644
--- a/libre/linux-libre-grsec/PKGBUILD
+++ b/libre/linux-libre-grsec/PKGBUILD
@@ -1,4 +1,3 @@
-# $Id$
# Maintainer (Arch): Daniel Micay <danielmicay@gmail.com>
# Contributor (Arch): Tobias Powalowski <tpowa@archlinux.org>
# Contributor (Arch): Thomas Baechler <thomas@archlinux.org>
@@ -120,7 +119,7 @@ build() {
}
_package() {
- pkgdesc="The Linux-libre kernel and modules with grsecurity/PaX patches"
+ pkgdesc="The ${pkgbase^} kernel and modules with grsecurity/PaX patches"
[ "${pkgbase}" = "linux-libre" ] && groups=('base')
depends=('coreutils' 'linux-firmware' 'kmod' 'grsec-common' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country'
@@ -137,7 +136,7 @@ _package() {
# get kernel version
_kernver="$(make LOCALVERSION= kernelrelease)"
_basekernel=${_kernver%%-*}
- _basekernel=${_basekernel%.*}
+ _basekernel=${_basekernel%.*.*}
mkdir -p "${pkgdir}"/{lib/modules,lib/firmware,boot}
make LOCALVERSION= INSTALL_MOD_PATH="${pkgdir}" modules_install