summaryrefslogtreecommitdiff
path: root/libre/linux-libre-firmware/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre-firmware/PKGBUILD')
-rw-r--r--libre/linux-libre-firmware/PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/libre/linux-libre-firmware/PKGBUILD b/libre/linux-libre-firmware/PKGBUILD
index fbd16f431..cb6ebb17d 100644
--- a/libre/linux-libre-firmware/PKGBUILD
+++ b/libre/linux-libre-firmware/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=linux-libre-firmware
pkgver=1.2.1
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='Firmware files for Linux-libre'
arch=('any')
@@ -30,11 +30,12 @@ conflicts=('linux-firmware'
'openfwwf'
'ath9k-htc-firmware')
replaces=(${conflicts[@]})
-options=(!strip)
-source=("$url/$pkgname-$pkgver.tar.lz"{,.asc} 'remove-external-toolchains.patch')
+options=(!buildflags)
+source=("$url/$pkgname-$pkgver.tar.lz"{,.asc} 'remove-external-toolchains.patch' 'install-ath9k_htc-on-prefix-ath9k_htc-too.patch')
sha512sums=('dc4f2e931b4dde217f2e3430e7a0c1a5f42f0844087bf9a771c7e40dbdd8050205d7a80495bd130f87a02a823db7514241d68bfded19548132b3620d4c7e630a'
'SKIP'
- '19732ee8e8320a143fee462ae79ca4551672bebc425e71dffd0a8d01fb7a7a02c822966c57072becfff5da11e2a6abe4a0f6de93e9c218bba0b594421a541150')
+ '474fcfad6c447fded19c8d678b5e29e21d6e1406a3350453e483fd1fe4031c5b3da754fdb94174a538c026ab0b266f7f794f60868c5d6b438aacbdbd214c1046'
+ '9aea747fe09593ca407cb638964613720f871cbf2ae480b300e881d3f209692dace6f7c3ee65478a8f3715949bc8b41460dbd25344433df9facdcf318815a177')
validpgpkeys=('F611A908FFA165C699584ED49D0DB31B545A3198') # Jason Self
prepare() {
@@ -42,6 +43,9 @@ prepare() {
# do not download toolchains so we can build offline
patch -p1 -i $srcdir/remove-external-toolchains.patch
+
+ # https://labs.parabola.nu/issues/1445
+ patch -p1 -i $srcdir/install-ath9k_htc-on-prefix-ath9k_htc-too.patch
}
build() {