summaryrefslogtreecommitdiff
path: root/libre/linux-libre-firmware/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre-firmware/PKGBUILD')
-rw-r--r--libre/linux-libre-firmware/PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/libre/linux-libre-firmware/PKGBUILD b/libre/linux-libre-firmware/PKGBUILD
index eb82af49b..45b5ff001 100644
--- a/libre/linux-libre-firmware/PKGBUILD
+++ b/libre/linux-libre-firmware/PKGBUILD
@@ -50,6 +50,12 @@ build() {
# create firmware folder to put the free firmware files there
install -d -m755 $pkgdir/usr/lib/firmware
+ # fix path on configure file
+
+ sed -i 's|$PWD/../toolchain/inst|/usr|;
+ 's|xtensa-elf|xtensa-unknown-elf|;
+ ' target_firmware/configure
+
# compile ath9k-htc-firmware
make -C target_firmware