summaryrefslogtreecommitdiff
path: root/libre/linux-libre-firmware/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre-firmware/PKGBUILD')
-rw-r--r--libre/linux-libre-firmware/PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/libre/linux-libre-firmware/PKGBUILD b/libre/linux-libre-firmware/PKGBUILD
index 298491a62..cd5cbaac4 100644
--- a/libre/linux-libre-firmware/PKGBUILD
+++ b/libre/linux-libre-firmware/PKGBUILD
@@ -5,13 +5,12 @@
pkgname=linux-libre-firmware
pkgver=1.1
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc='Firmware files for Linux-libre'
arch=('any')
url='https://jxself.org/firmware'
-license=('GPL3' 'GPL2' 'MPL')
-depends=('ath9k-htc-firmware')
+license=('GPL3' 'GPL2')
makedepends=('cmake' 'gmp' 'gperf' 'arm-linux-gnueabi-gcc' 'sh-elf-gcc' 'sh-elf-newlib' 'xtensa-unknown-elf-gcc')
provides=('linux-firmware')
conflicts=('linux-firmware'
@@ -28,7 +27,8 @@ conflicts=('linux-firmware'
'rt2x00-rt61-fw'
'rt2x00-rt71w-fw'
'amd-ucode'
- 'openfwwf')
+ 'openfwwf'
+ 'ath9k-htc-firmware')
replaces=(${conflicts[@]})
options=(!strip)
source=("${url}/${pkgname}-${pkgver}.tar.lz"{,.asc}
@@ -37,7 +37,7 @@ source=("${url}/${pkgname}-${pkgver}.tar.lz"{,.asc}
)
sha512sums=('4ef111f86e8a87bab31e02be171e09f47d71884f1737f5329e9dd07e9f799436d8ff2de5aa0b2cfb4bc921ed02bb2b59b9a1ea69176dcef5f902364d8725e75a'
'SKIP'
- 'ed4af53a48efd512809a490f9f558fc94f71950b847547bbec175c3bf805fa2bf7c6fea6cec77f454e37d4650b6339c384f5458b979221490921935bd7c044d1'
+ '60b58bed66e737148a5954c18efb1113518f14cf43ee2b6e7e8cdabe253a6db1c0d696f01eb25ecda7a8d3300afcf0169fa35f5eb123211554f08710f2c26ea2'
'4e596db89f88ed24db3eaff8ed2853d2a07128ba430a26bc63e08f29e4cd4c7093d358df35f580ede563103f0cf720f0f81f517108c79e80d8cf2aee786023f4')
validpgpkeys=('F611A908FFA165C699584ED49D0DB31B545A3198') # Jason Self
@@ -60,7 +60,7 @@ build() {
# however compiling it manually (without makepkg) on a 64-bits machine works.
# Building with makepkg in a 64-bits system or chroot ends into a segmentation fault.
# Source: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=887320
- make cis isci keyspan_pda openfwwf av7110 dsp56k usbdux carl9170fw # ath9k_htc
+ make
}
package() {