summaryrefslogtreecommitdiff
path: root/libre/linux-libre-dtb/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre-dtb/PKGBUILD')
-rw-r--r--libre/linux-libre-dtb/PKGBUILD16
1 files changed, 16 insertions, 0 deletions
diff --git a/libre/linux-libre-dtb/PKGBUILD b/libre/linux-libre-dtb/PKGBUILD
index 8f5711d30..c14d9194c 100644
--- a/libre/linux-libre-dtb/PKGBUILD
+++ b/libre/linux-libre-dtb/PKGBUILD
@@ -17,6 +17,8 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasever}/li
"http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasever}/linux-libre-${_pkgbasever}.tar.xz.sign"
"http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgver}/patch-${_pkgbasever}-${_pkgver}.xz"
"http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgver}/patch-${_pkgbasever}-${_pkgver}.xz.sign"
+ # the main kernel config files
+ 'config.armv7h'
"https://repo.parabola.nu/other/rcn-libre/patches/${_pkgver%-*}/rcn-libre-${_pkgver%-*}-${rcnrel}.patch"
"https://repo.parabola.nu/other/rcn-libre/patches/${_pkgver%-*}/rcn-libre-${_pkgver%-*}-${rcnrel}.patch.sig"
'0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch'
@@ -31,6 +33,7 @@ sha256sums=('48b2e5ea077d0a0bdcb205e67178e8eb5b2867db3b2364b701dbc801d9755324'
'SKIP'
'335d3e07319ddf393c69e047c27bc5d28ee9e6126282619e3364db56a4331d34'
'SKIP'
+ 'ba2bc52b7be477c362af2b5267ec07efdf2ba5afee4a07ac0df1dd47720d90e5'
'b06ab02787e6a61227d91faeaa3f230a3807f6426c388129a1d89150374e8b5b'
'SKIP'
'203b07cc241f2374d1e18583fc9940cc69da134f992bff65a8b376c717aa7ea7'
@@ -66,6 +69,19 @@ prepare() {
patch -p1 -i "${srcdir}/0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch"
patch -p1 -i "${srcdir}/0007-set-default-cubietruck-led-triggers.patch"
patch -p1 -i "${srcdir}/0008-USB-armory-support.patch"
+
+ cat "${srcdir}/config.${CARCH}" > ./.config
+
+ # load configuration
+ # Configure the kernel. Replace the line below with one of your choice.
+ #make menuconfig # CLI menu for configuration
+ #make nconfig # new CLI menu for configuration
+ #make xconfig # X-based configuration
+ #make oldconfig # using old config from previous kernel version
+ # ... or manually edit .config
+
+ # rewrite configuration
+ yes "" | make config >/dev/null
}
build() {