summaryrefslogtreecommitdiff
path: root/libre/libtasn1/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/libtasn1/PKGBUILD')
-rw-r--r--libre/libtasn1/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/libre/libtasn1/PKGBUILD b/libre/libtasn1/PKGBUILD
new file mode 100644
index 000000000..2131a323b
--- /dev/null
+++ b/libre/libtasn1/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id$
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
+pkgname=libtasn1
+pkgver=3.2
+pkgrel=1.1
+pkgdesc="The ASN.1 library used in GNUTLS, Parabola rebranded"
+arch=('i686' 'x86_64' 'mips64el')
+license=('GPL3' 'LGPL')
+url="http://www.gnu.org/software/libtasn1/"
+depends=('glibc' 'texinfo')
+options=('!libtool')
+install=libtasn1.install
+source=(http://ftp.gnu.org/gnu/libtasn1/${pkgname}-${pkgver}.tar.gz{,.sig})
+md5sums=('1b07629163025b9693aae9b8957842b2'
+ '67bdae9b78ac7bbfa2ab24c7d46bd577')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --with-packager="Parabola GNU/Linux-libre" \
+ --with-packager-bug-reports="https://labs.parabola.nu/" \
+ --with-packager-version=${pkgver}-${pkgrel}
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make check
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}