summaryrefslogtreecommitdiff
path: root/libre/libquicktime-parabola/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/libquicktime-parabola/PKGBUILD')
-rw-r--r--libre/libquicktime-parabola/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/libre/libquicktime-parabola/PKGBUILD b/libre/libquicktime-parabola/PKGBUILD
new file mode 100644
index 000000000..611608c68
--- /dev/null
+++ b/libre/libquicktime-parabola/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 116382 2014-07-26 16:36:46Z bpiotrowski $
+# Maintainer (Arch): Federico Cinelli <cinelli@aur.archlinux.org>
+# Maintainer (Arch): Mateusz Herych <heniekk@gmail.com>
+# Contributor: Jorge Lopez <jorginho@lavabit.com>
+
+pkgname=libquicktime-parabola
+_pkgname=libquicktime
+pkgver=1.2.4
+pkgrel=10
+pkgdesc="A library for reading and writing quicktime files, without nonfree faac support"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://libquicktime.sourceforge.net/"
+depends=('gtk2' 'ffmpeg' 'libxv' 'libxaw' 'faad2')
+makedepends=('mesa-libgl' 'x264')
+source=("http://downloads.sourceforge.net/sourceforge/$_pkgname/$_pkgname-$pkgver.tar.gz"
+ ffmpeg2.0.patch)
+sha256sums=('1c53359c33b31347b4d7b00d3611463fe5e942cae3ec0fefe0d2fd413fd47368'
+ 'a1c8415e8e7bc04c81b946b9e3746f7d5ef24819135962280c3a7ddb3f2baa2b')
+replaces=("${_pkgname}" "${_pkgname}-libre")
+conflicts=("${_pkgname}" "${_pkgname}-libre")
+provides=(${_pkgname}=${pkgver})
+
+prepare() {
+ cd $_pkgname-$pkgver
+ patch -Np1 -i ../ffmpeg2.0.patch
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --enable-gpl \
+ --with-ffmpeg \
+ --with-x264 \
+ --without-doxygen
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}